Eaton Z wave

Hello, I am new to Hubitat. I am trying to pair Eaton Z wave switches RF 9601 and RF 9617 (master and accessory switch ) for a 3 way set up. How do I do this using Hubitat? There is no traveler wire in the RF 9617. Thank you.

Looks like the 9601 is meant to be the master switch and the 9617 is the “accessory”. So just need to pair them with each other and include them with HE.

On eaton they are both zwave devices, and then need to be coupled via zwave associations after pairing. Not sure if the Hubitat Eaton drivers will provide for setting the association, though, so you may need to use one of the association tools/drivers.

But that is a problem for AFTER you get them paired.

Put the hubitat hub into pairing - devices -> Discover Device -> Zwave -> Start Zwave Inclusion - then follow the pairing instructions in the device manual.

I use the Eaton RF9600 series devices throughout my home. @thebearmay is correct the RF9617 is not intended to perform any physical control. And @JasonJoel is also correct. You have to get all of your devices paired to HE first.

To set up 3 and 4+ way control you either have to write rules (Simple Automation or Rule Manager, etc.) or setup direct associations between the devices. I prefer the latter. I believe it makes my automation system more resilient to failures. In the event my HE is offline my 3 and 4-way switches still function. Setting an association gives a device permission to send a limited set of commands to the target device.

Here is a post of mine on this very subject. It isn’t difficult. It just requires careful planning. Eaton devices use the following association groups:

Group 1 - Lifeline.
Group 2 - ON/OFF
Group 3 - Dim Up/Down. Only on the 9640 and 9642

Do not use Group 1. We can have an esoteric discussion about why another time.


Thanks for your reply. Just to explain myself further, I moved to Hubitat after almost 7 years in Smartthings. The 3 way switch/accessary switch in quetion was GE Jasco till few weeks ago. It stopped working and then I installed eaton 3way + accessory. The GE had a traveller wire and hence there was no issue. But the Eaton accessory switch doesn't have that. Both the main 3 way switch + accessory are connected to the Hubitat hub by z wave without issues. I can control the actual recessed lights using hubitat app or manually pressing the 3 way switch without issues. However, when I press the accessory switch, nothing happens- cannot control the light. I tried using the rule machine, but no success. I am just a bit lost as to how to wirelessly connect the accessory switch to the main 3 way switch and hence control the recessed light. I really don't understand the Eaton association. Could you please explain in layman terms what I need to do? Thanks again.

I'm sorry about the delay in getting back to you. I was travelling to investigate a robotic lawn mower.

Welcome to the joys of DIY home automation. Every time you look at a possible device to use, you have to go over how it wires in, configures, and is intended to interact with the hub and other components in great detail. Every one of us here has brought some device(s) that didn't work the way we thought they would. It is part of the experience (fun?).

The RF9601 can work with a traveler wire. It expects a dumb toggle switch on the other end. This is the simplest solution for you. NOTE: the dumb switch is NOT a 3-way switch. It is a basic toggle switch. Here is the wiring diagram for this configuration.

So, put the 9617 in your extra automation parts bin and try wiring it up this way.
Let me know how it turns out.

I also tried wiring above way (with toggle ) several days ago. Tried the z wave companion switch from GE as well as a regular toggle switch. For the GE z wave companion switch connected to the Eaton master 3 way, the only way it would function was if I kept it pressed all the time. Once the finger pressure was released from the companion switch, it was turning the lights off. So I went back to wiring with eaton z wave 3 way + companion without a traveler and tried to figure out how to make them communicate by RF. That is when I posted this in the message board. Last night, I did copy the Z wave association tool with github link and copied it to the apps code. Then I played with the association, but still no luck.

After my last message few minutes back, I once again tried using the rule machine. When I physically press the accessory switch, the lights do turn off and on, but there is a 2-3 second delay. I guess this is better than before, but ideal would be direct RF connection between the 3 way and companion switch without going through the hub. Still not sure how to do that. Thanks for all the messages and advice though.

Excellent! You have devices that are paired and can function as desired. Let's get them associated.

Pause your RM rule that connects these two devices.

Find the Z-wave IDs of the two devices you are going to associate. Here is an example of a pair of mine as an example.

The Z-wave IDs are circled in green.

Open the device page for one of your devices. It doesn't matter which right now. Look for the "Advanced" section. It should look like this.

Click on the word Advanced. Now it should look like this.

The command you need to send is made up of the following parts:
Command Class: 85
Set command: 01
Association Group: 02 (of the source device)
Device Network ID [of the device to be controlled]: (Use the ID of the other device)

The command you should enter where it say "Send ZWave Command*" will begin like this:


Now add the two characters for the Z-Wave ID (DNI) of the divide you want this device to control.

Press the "Send Command" button. There isn't any feed back. You press it. It's done.

Now open the other device and do the same thing except you use the ID of the device you just left.

This should get these two devices communicating directly. It will be faster than a executing a rule.

A side benefit of direct association is, these two device will continue to communicate even if you take your hub offline. The association commands you just sent them gives them permission to send each other on/off commands.

My switches are numbered 3A and 3B.
So I tried using the commands 8501023A and 8501023B. I paused the RM as you said. It hasn't worked. I am attaching the snapshots.

Have you added the "Basic Z-Wave Tool" driver code to your system? If you haven't here is a link to it.

HubitatPublic/examples/drivers at master · hubitat/HubitatPublic (

If/once you have it added in Drivers Code, you can temporarily change the drive for each of these devices to the "Basic Z-Wave Tool". You should now find this button at the top of the commands.

Press this button. Go to the Logs page and choose "Past logs". Select your device. The output should look something like this.

The association on group 2 should show the ID of the other device. If it doesn't, send the appropriate command again.

It took me a few times on some of my devices too. At least until I got the hang of it.

Do I copy the whole file- meaning all the lines from 1 to 162 to the drivers code? Sorry, i have never done this before

Go to the link above for the Basic Z-Wave Tool. The page should look like this:

Click on "basicZWaveTool.groovy". That should take you here:

Click the "Raw" button.

When the next page appears, select the entire address of the page;

Open the "Drivers Code" page in HE.

Press the "New Driver" button.

Press the "Import" button.

Paste the URL you copied from GitHub here.

Press "Import". Choose Yes to the question about replacing the existing code. Then press "Save".

Congratulations! You've just added your first community driver.

1 Like

I added the community driver as per your instructions.

But I dont see the 'get association report' icon under devices. Not sure what I am doing wrong.

Did you go into Devices and create a device using the driver or change an existing device to use the driver?

No I didn't do this step but not sure how. I added the driver though as you said.

All i see in the device page for this switch is this

Scroll down below Preferences to the Device Information section and change the type to the Basic Zwave Tool driver (it will be near the bottom of the list after all of the built-in drivers

@hmanian Did you get your switches working the way you want?

I did try all the above but couldn't get to make the direct association. The accessory switch still works through the hub after few seconds delay. I kind of gave up. Thanks for your help anyway.