Duplicate Hubitat Package Manager

I've discovered that my Hubitat somehow has two instances with two different versions. Not sure how I managed to get to this, and so far I have not managed to delete the older one. Was working yesterday with a problem involving Kasa Plug driver/application having wrong IP address. Maybe I made a mistake there.
Have tried to delete both of them, but always get errors about application in use.

Any suggestions on how to get back to just one HPM?

I had the same problem (two installs listed) but was able to figure out which was the older one (the uninstall doesn't show the version, just the title so you have to guess) and it uninstalled. Or acted like it did anyway.

Do a repair on one of the instances to make sure that you are on the latest release, then use the Unmatch option to remove the lower version.

Solved back in June. :slight_smile: (Notice how I'm pretending June is a LONG time ago? :smiley: )


I'm not sure which package it's concerned about...

Also solved a couple weeks ago..

Hubitat release a Platform update to solve that AND the workaround is just click to close the pull down and then click the twisty again to open.

Release Available Changes from Bug Fixes Fix for enum dropdowns appearing to be populated with nulls.


Worked like a charm! Thanks!

Problem solved.
Thanks to csteele. Unmatch did the job handily.
All up to current versions now. :grinning:

1 Like