Drivers for Sunricher Z-Wave LED controller SRZV9101FARGBW

Hello, I'm fairly new to Hubitat and the forums.

I have a Z-Wave RGBW LED controller SRZV9101FARGBW which I believe is the OEM rebranded version of the RGB Genie ZW-1002.

As the Sunricher is the same hardware I thought the Hubitat_RGBGenie driver would work (Zwave-LED-Controller.groovy), but this looks like not compatible as it doesn't talk to the device at all - no commands work e.g. on/off and the settings page is not getting any info from the device. Under Device Type it shows 'The device type has not been detected'.

I've tried all other built-in LED type drivers and the only one that seems to work is the "Hank RGB LED Bulb". This works great with RGB colours, but seems a bit off controlling the White, where the colour temperature works opposite to the way it should (a higher value gives a warmer colour not cooler).

Any advice on whether there is a driver that has better support for this Sunricher?

Many thanks

Hello, I am not sure if you tried this, but sometimes hitting "configure" in the device settings page can make a device work properly. You don't usually need to do this upon pairing, but if you swap drivers you probably should.

Other than that, lets tag @bcopeland as he is the Zwave guru around here. Maybe he has some insight here.

And welcome to the Hubitat community.

Much appreciated and thanks for the warm welcome. I did do a good amount of 'button mashing' on the settings page including configure :), it looks like it can't detect or start a dialogue with the device.

@bcopeland grateful for any insight you have. Definitely looks like the right driver for the device in theory, as the light effects in the device instructions (referred to as 'light stage mode') are identical to the code described in the driver with values 0 to 7.

Few items in the log including error at the top:

dev:1952020-11-15 06:19:42.525 pm errorgroovy.lang.MissingMethodException: No signature of method: user_driver_rgbgenie_RGBGenie_LED_Controller_ZW_489.ping() is applicable for argument types: () values: [] Possible solutions: find(), print(java.lang.Object), print(java.io.PrintWriter), print(java.lang.Object), find(groovy.lang.Closure), run() (ping)

dev:1952020-11-15 06:17:39.953 pm debugFirmware: 1.05

dev:1952020-11-15 06:17:39.757 pm warnconfigure...

dev:1952020-11-15 06:17:39.713 pm warndescription logging is: true

dev:1952020-11-15 06:17:39.711 pm warndebug logging is: true

Many thanks

Oh, something just jogged something in my brain. Bryan (bcopeland) actually wrote a community based driver for these that you might try. I don't know how or if it differs considerably from the stock driver, but it might be worth trying.

These are available in the Hubitat Package Manager. If you haven't yet installed that, it makes finding and installing apps and drivers MUCH easier. (search for RGBGenie in HPM)

Thanks, that's the one I'm using the latest community driver Zwave-LED-Controller.groovy.

I've done some further digging on this problem with the Zwave-LED-Controller driver (for RGBgenie devices).

@bcopeland are you able to shed any light on why the driver is failing? I'm still getting errors in the log as the driver is not able to get off the ground - no commands work e.g. on/off and the settings page is not getting any info from the device. Under Device Type it shows 'The device type has not been detected'.

I have a Sunricher SRZV9101FARGBW which is an OEM version of the RGB Genie ZW-1002. The driver has a few fingerprint definitions at the start for the various RGBGenie devices and I wanted to make sure my device was actually the same as RGB Genie, so I've forced the device to show this in the logs. My device does indeed report itself as the EU version of the RGBGenie, with all these being exactly correct as defined in the first fingerprint for EU device:

  • Manufacturer code
  • Product code
  • Device id
  • In cluster list

Results from the hubitat log are:
dev:1992020-12-29 06:38:16.194 pm info fingerprint mfr:"0330", prod:"0200", deviceId:"D002", inClusters:"0x5E,0x55,0x6C,0x98,0x9F"
dev:1992020-12-29 06:38:16.171 pm debug building fingerprint for unknown Z-Wave device...

So I'm wondering if it's the right device, why won't the Zwave-LED-Controller driver talk to it?

Here is the error log from the driver in case it helps:
dev:1992020-12-29 07:04:21.303 pm trace setColor not supported on this device type
dev:1992020-12-29 07:04:21.283 pm debug setColor([saturation:100, hue:25, level:100])
dev:1992020-12-29 07:00:38.923 pm error java.lang.NullPointerException: Cannot invoke method toInteger() on null object on line 254 (updated)
dev:1992020-12-29 07:00:38.884 pm debug deviceModel: null Updated setting: null

Thanks for any advice :slight_smile:

The community driver wasn't setup for proper C7 secure encapsulation... I just updated it..

That's amazing! Just tested with all the features and everything works as it should.

Thanks so much for the update, it's really appreciated. You are a true star :star:

1 Like

Download the Hubitat app