[DRIVER] Zooz ZEN55 DC Sensor (for Smoke/CO Alarms)

Installed one of these this weekend and it sounds like I had the same issues @velvetfoot had back in November. Initial install went well, did a test and saw the device indicate smoke. An hour or so later I saw on the Zooz firmware site there was an update that addressed the issue of the device going offline. Went to update firmware and the device gave me the same error, listed back in Velvetfoot's post. So I tried config and refresh and it just hung saying 8 pending changes.

That is when I went searching on here and found this thread. I power cycled the device and then it started working and I was able to update. It said it updated but it still shows 1.2 as the firmware version. The LastcheckInDate state variable is updating, so I think it is good. I have added it to my activity monitor, so I will keep an eye on it. I test my alarms once a month, so we will see what it does on my next test cycle.


Configure and/or Refresh should force a firmware version check on the driver side and update the data. You can turn on debug logging to confirm in the logs.

I had done a configure/refresh a few of times and it never changed the value in the data section from 1.2 to 1.3. So I just turned on debug logging and did a configure and I got confirmation that it was 1.3 and now the data section shows 1.3 as well. I wonder why it didn't update until I tuned on debug logging?

If it had pending changes still when you ran configure before it does not do the full process it just tries to clean up what is not synced up. You have to be fully synced for it to do the version check during the configure.

Showed that it was.

I use Device activity check but the Zen55 does not seem to be responding. I see the state variable lastcheckindate is being updated, but there is nothing in the events log and the DAC app shows no activity. I have it set for 24 hours.

Is there an option I am missing to get the DAC app to do a refresh?

Yes, it is on the page where you select the devices for that "group."

1 Like

Don't know how I missed that, thanks. :+1:

The lastcheckindate is internal for the driver. It should only update if the device sends something to the hub, but maybe it is sending something in that I am not parsing into an event. Might have to run mine with trace logging for a couple day to see if it is sending in some sort of keepalive.

DAC uses "LastActivity" from the bottom of the device page. Which gets updated any time the driver posts an event. Please note when the refresh happens if the device responds it will post an event but it will probably NOT be a state change, so it does not show in the event log, however it will still update the LastActivity date.

1 Like

FYI all, I confirmed with @agnes.zooz that the ZEN55 works with Heat Alarms as well (e.g. First Alert Hardwired Heat Alarm with Battery Backup, BRK Brands HD6135FB)! They're going to update their documents to indicate the support.

A concern I had through was that the heat alarm triggers once the temperature reaches 135 deg F or if the heat rises more than 15 deg F in 1 minute, and the ZEN55's operating temperature range tops out at 104 deg F. Zooz said "The ZEN55 may still work above 104 deg F, however, we cannot guarantee it would report at temperatures higher than the recommended operating temperature." I'm hoping it'd be protected behind the alarm in the junction box long enough to send the alarm before it died... hopefully I never find out. Regardless, a good way to integrate heat alarms!


QQ I setup the ZEN55 and all was working as expected until I tried to mesh the device to my other hub. With the most current community driver it refused to mesh to my other hub. I was able to change the driver get it to mesh and then flip it back to the proper driver. I use one hub c8 for the radios/devices and a second c7 for apps and rules.

Any idea why this would occur ?

Can't say why it doesn't work, but this sounds just like my setup. The Zen55 is on a C8 and I have it meshed to a C7 where my rules are located. I had no issues doing that.

1 Like

If you mesh something with a custom driver does it transfer the driver to the other hub automatically? I think thats what it is supposed to do, so maybe there was an issue with that or a platform issue that has recently broke that? There is nothing special that a driver needs to work with hub mesh so it is not a driver problem.

1 Like

Just had this condition happen again, the ZEN55 went dead no lights no response, couldnt default it 100% dark. Got a replacement and it refused to mesh with the correct driver installed I shifted it to a generic switch then flipped it back and it now meshed

Yes, this was recently identified as an issue with Hub Mesh and the way I defined some of my settings, in only some of my drivers. I have a workaround but have not deployed it to this driver yet. Next update will have that fix and I am also going to add some sort of health check for this device since it does not regularly check in but has a critical function.

1 Like

Admittedly, I don't test my smoke alarms enough. :slight_smile:

Anyway, I hit "Refresh" on the device page and nothing appeared in the logs, but I do get the below, so I guess it's working, right? I'll have to check the alarms when the cat is out of the house...she hates it.


Well, she was on the porch, and I closed the door.
(I got the feeling she still didn't like it.)
Anyway, it works.
Good to test every once in a while. :slight_smile:

You would have to turn on debug logs to see anything, since it is just duplicated events. The last activity (what DAC uses) or the lastCheckInDate is your only visual that it responded. Both of those should only update if the device sends a reply back.

Awesome! I look forward to it

Keep in mind the devices themselves have a shelf life...most are 7-10 years

1 Like