Driver connecting to insecure URL


I have a driver that needs to connect to a server via wss:// (secure websockets). The server has a self-signed certificate and of course fails validation:

webSocketStatus() - status: [failure: PKIX path building failed: unable to find valid certification path to requested target], State: [initialize]

I'm following the websocket interface docs here:

But I can't find a way to either ignore certificate issues or to add the CA cert to bundle on my hub.

You can add this option:

interfaces.webSocket.connect(url, ignoreSSLIssues: true)

You can also install your own certs to Hubitat, but I haven't done that personally so someone else can chime in if you prefer that path.


I don't think this was ever implemented, but if it was, it should probably be something like ignoreSSLIssues: true passed as part of your options map.

EDIT: So, basically, what was written above as I was typing. :slight_smile:


Awesome, that actually worked! Someone should update the docs and add that argument.

1 Like