Dresden FLS-PP Device Code (migrating from ST)

Hi all! First post here! I am stuck on setting up my Dresden FLS-PP RGB (zigbee) controller.

I can pair it successfully and turn on/off the white LEDs but, I am having an issue with controlling the RGB LEDs. The "kicker" is the RGB is stuck in green and I cannot not turn it off unless I unplug it. haha

I am migrating from ST so I tried copying the DH into the Drivers Code but, it does not help. Still only able to control the white.

Anyone have this device successfully working?

Thank you!!

I have just used the generic RGB driver with them without too much issue (I do not have any RGBW strips to use with them). Although I have not used mine much lately (been too focused on exterior RGB lighting).

Thanks snell! I tried all the different drivers but all do the same thing.

One thing that I noticed. There are two endpointid's: 0A and 0B. (the FLS-PP will discover as two devices). When I discover it, it shows both endpointid's

Once I have saved it, in the device details/data, it only shows endpointid: 0B.

I am almost positive endpointid 0B is to control the white LEDs.

Any guidance is appreciated!! Tried to post pictures but it won't allow me. Edit: pictures attached Thanks again

That seems like a lot of duplication when it finds it... I will try removing one of mine tomorrow (just noticed the time, so I should say later today) and see how different mine look. Maybe you have a newer model or such and they "tweaked" it.

Before you go through the trouble of removing it what do you see in the Device Details?

At some point, Dresden updated the firmware and I believe I have the latest (purchased Mar/2017). If not, this device does not support OTA updates so not much I can do.

I tried changing the Zigbee channel to different channels to see if that helps but it doesn't make a difference. (think I read somewhere some channels do not work with zigbee light link).

So far I am LOVING HE. I hope I can work this out!!

My Dresdens are pretty old. I also confirmed that the driver I am using is the Generic ZigBee RGB Light, and it is working just fine (even though I have no had it plugged in for a bit, it started right up and responded to color change commands). As for ZigBee channel... I use 20 because I read it worked best for Securifi Peanut Plugs and I have a TON of those scattered around. Changed it nearly the first day I got my HE and have never gone back.

Here are the device details for one of them:

  • endpointId: 0A
  • application: 02
  • softwareBuild: 020C.2000004F
  • inClusters: 0000,1000,0004,0003,0005,0006,0008,0300
  • outClusters: 0019
  • model: FLS-PP3
  • manufacturer: dresden elektronik

snell- Thanks you so much! That is a big help to troubleshooting!:+1::+1::+1:

When you paired your devices, it paired to "0A" which is the RBG channel. Mine is pairing to "0B" which is the white channel.

Anyone know if there's anything I can do?

BTW- This device code separates the white and color LED's to control independently.. not sure if it works in HE but it worked in ST.


Actually... I just checked my second one and it is paired as:

  • endpointId: 0B
  • application:
  • model:
  • manufacturer:

Need to go check if it actually works. Cannot remember the last time I used that one at all as one of the retaining clips broke.

Did you find out? Having one in front of me and can only control the white channel.

Actually I have not used mine since then. Moved to newer (and smaller) varieties of RGB LED strip controllers (like the Zen31 for Z-Wave or a GLEDOPTO ZigBee one) and have not used my Dresdens in a long time. Still in my parts bin...

Too bad. I'm having some issues with one that won't let me change color. It's just the white that's connected.
I tried to get the ST driver to work but still only get to control the white channel. I'm afraid that this device needs a driver with a Parent/child function.

It did not used to... let me warm up one of mine and see what it is doing.

So I had to reset and rediscover both to even have them get working at all (not surprising since they had been unplugged for a year). I set them both up with the "Advanced ZigBee RGBW Bulb" driver.

One device identified as an "endpointId: 0B" is NOT controlling it's RGB at all, but THINKS it is controlling something (I assumed the W). Just to test this I moved the G line over to the W and sure enough, it is being controlled now. So basically this FLS-PP is acting like a single-color controller.

The other device that identified as an "endpointId: 0A" is controlling the RGB perfectly but is NOT controlling the white at all. I moved the R line over to the W for my LED strip and set the color temperature (so it would primarily do white)... and all it did not get any red at all. So the W line appears to be non-functional.

I tried using a Dresden FLS-PP driver original intended for SmartThings that someone converted but that did not change the results at all.

You've come to the same stuff I did. I managed to get, from the Hubitat public Github, the generic RGB Zigbee driver. I then hardcoded the 0A (which is RGB) in, otherwise it would default to the 0B endpoint which isn't RGB, but just the White.

So I got some functionality out from it, but I still think the best driver would be one, which splits it up in a parent/child setup.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.