Does Hubconnect Work With The C-7

Ok I have followed the same instructions that i used to connect my C-5 hub To my C-4 hub and my Smartthings to my C-4 hub and everything went well. I tried connecting my new C-7 hub through hubconnect and to say the least it has not gone well i cannot get any device from the server hub to show up in the C-7 remote hub. As I said I followed the same instructions so what gives?

I have my C-7 connected with my C-5, so I'm gonna say yes

After I got it set up on mine and worked fine. You have all the necessary HubConnect drivers installed on your C7?

Copying @csteele.

Yes like I said I made sure i followed the exact same method and instructions I used to install on my C-5 and my smartthings hubs, something is not right all of the drivers are installed on my main hub my C-4 unlike my C-5 and smartthings hub the correct name isn't even showing up even though i put it in there it only says Hubconnect server instance.

I have 2 of the C-7's using HubConnect to connect to other Hubs. One of the C-7's is working as a Remote to 3 Hubitat Hubs plus ST and Homebridge. The second C-7 is acting as HubConnect Server to a C-5 in my development pair.

So I have one in each 'role'. Server and Remote. All of my HubConnect instances are using v2.0 RC2, although I doubt that matters. What does matter, of course, is that they be on the same vintage.. either all v1.6 or v2.0

Iv'e done that like all day long I have installed and uninstalled this instance 80 to 90 times now and nothing is working as i stated I saved the link to the instructions i did everything in the same manner as the first 2 hubs but this one is having problems somehting is wrong and it has to be with the hub all the drivers are in and correct the versions are the same the only difference is the C-7 hub.

I didn't see this mentioned above: have you seen anything of interest in the logs on either the server or remote hubs when you try to set things up? That would be the first place I'd look if things weren't working right, and it might give you clues as to what's wrong (or give csteele more to work with :slight_smile: ).

Let's make sure I know what you know... you have a C-7 that you're trying to add as a Remote to an existing Server? What version of HubConnect?

To get an additional Remote to connect to an existing Server, the Remote needs One App and One Driver, that's it. It needs the HubConnect Remote Client and the HubConnect Remote Hub driver. Once both of those are added to the Hub, you can open the Remote and select Connect to Server Hub.
Screen Shot 2020-09-16 at 7.35.50 PM

You pause there and go to the server and create a new instance...
Screen Shot 2020-09-16 at 7.36.50 PM

You enter the IP address of the Remote Hub, the C-7.Pick Hubitat (LAN) I presume, then HTTP (oAuth) because that is the simplest. The Key is created and it's ready to be copy pasted into the Remote. It will show Connected, probably and you can Next/done all the way out. Back on Server, click Verify and it too will say Connected. Done all the way out.

Visit the Remote Hub devices that get created and verify they have their Switches ON.

Screen Shot 2020-09-16 at 7.40.46 PM

This is all very basic and probably what you're doing but it can't hurt to say it all again, maybe one extra word is all the difference. :slight_smile: However, these instructions, especially "Verify" is v2.0 specific because I'm having to GUESS your version. :slight_smile:

Checked logs nothing of interest there, yes i'm trying to connect my C-7 as a remote to my server hub which is a C-4 going to delete the instance again and restart everything again and so how it goes, but yes I have the remote clent installed and the remote hub driver installed on the C-7

Ok guys again thx for all the help I just re did the instance and everything went great ijust checked the devices are appearing in both directions now and all is good. Thank you guys for all the help i'm going to bed now I just don't know how to explain this everything that I have done I just did but this time it worked the gremlins are out in my house tonight I tell you thx again for the third time.


It's afraid of me.



This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.