DOA Hubitat C-7 - no response

Hi, just received my C-7 this week and excitedly plugged it in. Got a blue light for a while but then nothing. Have unplugged the device overnight and tried again today but now I get no indicator light at all, also can't find the device on my network. Is there a reset or reflash procedure?


Welcome to the HE community, @graham2!

I'm sorry to hear you excitement got crushed by a DOA C-7 but it happens. @bobbyD will get you fixed up.

1 Like

If you are not seeing any lights on the hub, your problem is likely the power supply and a reset wouldn't help. Please try an alternative power supply and if you still don't see any lights, send us an email to along with your hub's MAC address (is printed on the hub) and purchase order details (if you didn't buy your hub from

1 Like

Thanks Bobby D. Yes I have tried another power supply and micro USB cable, still no response. Will email support as you suggest.


1 Like

Hi BobbyD,

I'm not sure if you are receiving my emails, I have sent through my MAC address and purchase details. Email was sent to as a reply. Case number is 19395.


Hi @bobbyD, just as an FYI... I received my Hubitat for the Holidays hub last week and it had a power supply problem. Sometimes it would boot but would eventually turn off/reboot on it's own. Wiggling the cable didn't provide any repeatable symptoms (and there's not much more there to debug :smiley:) so I just replaced both the cable and supply and it's been solid ever since.

Hi Mark,
Good to hear you were able to solve your problem. I have tried the same, with 2 known working USB power supplies and cables. Mines dead as a doornail unfortunately.

That sucks, I was hoping it was something simple. Real long shot, do the USB power supplies you used have at least 1A power available? That's the size that came with the hub but when I changed mine I upped it to a 1.2A. It's possible that 1A (if the brand of PS actually meets that spec) may be on the edge and with tolerances it just can't get your hub powered up.

I mentioned it to Bobby in case there are more reports of bad PSs so that he can monitor it.

I just tried a USB charging hub that has 2.4 amp ports. Not a sausage!

Bummer, knew it was a long shot but had to ask. Hopefully the HE support guys are taking care you.

Appreciate the suggestions. Thanks Mark.

1 Like

Apologies for dragging my thread back, I still have not recieved an answer about my DOA hub.
I don't know if I am supposed to mail my hub back, or if I can reflash it or do I throw it in the bin?

I realize there is currently no stock to get a replacement, and support are currently very busy, but it has been a week now with no response or acknowledgement.

Trying to be patient.

Thank you.

You are a very patient man. Hat off to you sir.
Hope you will get an answer soon.

Thank you for your patience. Please check your email :slight_smile:

Thanks to all for your support. My replacement hub is on the way. Looking forward to my future involvement in this fantastic community.

1 Like