Do not turn on if already on

One of my ML rules switches on three (scene activator) switches. Works fine except when any (of the three) switches is already on, then none of the switches are triggered and turned on by motion. I was rather hoping the two that are off would be turned on and the third, which is already on, would be ignored.

What is the intended behaviour here?

Post a screenshot of the Rule and of the Scene setup, I think that would help everyone see the concern.

1 Like

My gut feel is yes, but also that there are likely a few settings that may help give you what you need....

But like @jtp10181 mentioned, a screenshot is always helpful...

Attaching screenshots


Kitchen Scene
Entrance Scene

Maybe I just need the "Do turn on even if any already on"? I will try

That might work. I would also enable the logging in the motion rule (toggle at the bottom). The logging might give you hint as to why its not working. Sometimes it tells you why it stopped or did not execute the actions.

Also I see you have scenes but are turning them on with the switch device. There is also another option in there to activate the scene. I am not sure if this makes any difference in how it operates?

image

Also in the scene itself, there is a setting to On/Off optimization, this will prevent the scene from trying to adjust anything that it thinks is already in the correct state. For a small scene I usually leave that off so I know all the commands will go out, if there are a lot of devices in the scene that settings can prevent flooding the networks with un-needed commands.

Also could enable logging in the scene, which might give you further clues.

Activate Scene does not work in this scenario as it only provides the option to select one scene. I need three

The option ”do turn on even if any already on” sounds exactly what I need but it does not work. If one switch IS on, the the rule does not switch the others on. The logs shows ”not turning on, already on”

Download the Hubitat app