Disable Bulb On/Off Fading (Sengled Element Color Plus)?


I was wondering if anyone has found a way to turn the fade/transition entirely off for the on/off commands of the Sengled Element Color Plus bulbs? I recently discovered that when I enable the zigbee group messaging on a group of these bulbs and send a group on/off command, they instantly respond with zero fade time. I prefer this and would like this for individual commands as well.

I've tried both of the Sengled drivers available, as well as the Advanced RGBW, but it seems like any individual on/off command makes the bulbs slightly fade (even when transition times are set to ASAP).

Wondering if anyone has found a way to make this happen.

My understanding is that the Sengled bulbs themselves don't do any such fades (I do notice the "off" action is a bit of a fade, but probably just the characteristics of the LEDs themselves and not something they are intentionally doing in firmware--or it is and both are just hardcoded to be extremely fast). I do know that Hubitat's built-in Sengled drivers try to compensate for this by making them fade up/down for on/off commands via other means, using whatever setLevel() (which supports transition times) does instead. As you've noticed, this breaks with Zigbee group messaging since a "plain" on and off command is sent to the group, bypassing the tricks the driver is using for its specific "on" and "off" commands. In your case, I suppose that's actually desirable.

I'm not sure why the "Advanced..." Zigbee bulb drivers wouldn't be working as you expect, but there are options for on and off transition time in that one, so if you haven't tried setting those to ASAP, that's the first thing I'd try. (My guess is that higher values use the Sengled-esque trick of "Set Level" instead of traditional "On"/"Off" behind the scenes if you choose them instead, but I don't know for sure.) If you haven't tried hitting "Configure" after you change drivers, that may or may not also help. Past experience tells me the "Generic..." drivers do not have this "problem," either; this on/off behavior is one issue the Sengled-specific drivers were split out of this driver to address. I'd give one of these things a try if you haven't already.

Thanks for the suggestion, but I have tried the Advanced Zigbee RGBW one, at set them to ASAP, hit configure, and it still does the slight fade with individual commands.

An 'easy' solution is my "a group for all" approach. I make a group for damn near all devices even if there is only a single device in a 'group'.


Mainly, rules (now Node-red flows). If all rules are focused on 'groups', and a device fails/or you want to replace it. All you need to do is add the new device to the 'group', remove the old device, and 100% of your rules/automations still work.

This would also solve your dim on shut off issue, if a ZB 'group' msg is the work around.

FYI - if you don't use the color a lot (you can switch back on holidays lol) setting them to Generic ZB CT Blub also solves the problem. We do this with closest light strips that do not use color. They faded both up and down before and the wife nuts. maybe I should change them back :rofl: )

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.