Did update, now can't get devices back

Really annoyed. Did an update, having done creation and download of a backup beforehand. DB locked or something, so I did a soft reset. Then I did a restore. Then I get "get started" and "restore from backup" welcome screen. I have gone through every local backup, even reverting to previous matched versions to do so.

Is there a way to restore one of these backups and not have to go through my dozens of devices to include again?

This rly rly poor UX. The documentation is not providing a route to get my device usable again.

Help, or a recommendation for a Samsung hub that doesn't self-brick, please.


1 Like

Likely before the update your database had some corruption. Go to yourip:8081 and revert to the previous version. Do a soft reset again and restore from your pc when prompted. Once done. Shut down the hub, unplug power to the hub (at the wall not the hub) for a couple of min then power back up.

1 Like

Also check the version of your diagnostic tool. Should be .97, anything older may have issues with the current hub firmware. It is supposed to update itself so you should be updated but there is a chance it has not updated yet.


Thank you for the replies.
The diag. tool is v1.0.92

I've now tried the recommended procedure, with the unplugged step, through each backup (newer to older) with setting to a matched previous version.
In a month and change I accepted and successfully had three upgrades. I'm guessing it is unlikely the db was corrupt through each.
Is there to way to check hardware integrity, specifically the storage?
I've had my hub raised for convective airflow, and it runs off a USB UPS, so it's been coddled Pv-wise.

I'm hosed?

Follow this to see if you can get the diagnostic tool to update:

After that, you may need to try the soft reset one more time and restore from a backup.

If still not working, use the diagnostic tool to roll the firmware back to the last 2.3.2 (restore previous version) and try restoring your backup from that version.

1 Like

For hardware related issues, please create a case by visiting below page, and our staff will be able to further assist. If you are passed your warranty, and suspect a hardware issue, you can send me a private message and we can check your hub's engineering logs, assuming your hub is connected to the cloud.

How would I know it's a hardware issue though?
Is it a diagnosis by exclusion?
I had backups going back through three platform versions, and I am having the same behavior of just getting a "Get Started" splash screen.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.