Devices not included in dashboards

Went to add new devices to existing dashboards.


Some of the dashboards have existing devices previously added. Others have no devices selected. All dashboards are functional. Any ideas what could have happened and how to fix; other than adding devices over ?

In older platform versions, all devices were added by default to new dashboards. With the latest versions, devices must be manually be added when a dashboard is created.

Could this be what you are seeing, or are you saying that you had dashboards defined and on those dashboards, devices that you had added were removed?

If the latter, I would be concerned about database corruption (easily fixed by restoring a backup via a file on a PC).


The dashboards display correctly, however when adding a new device, via the dashboard menus, no devices are shown as already selected. I did a local restore, tried several older backups, no difference.

Just to be clear, from @Sebastien 's post, when you have added a new device to your HE hub, have you done the following:

  1. Opened the apps screen in your HE hub web UI

  2. Clicked on the dashboard you are interested in, listed under the "Hubitat (R) Dashboard" app

  3. Under the "Choose Devices" listing selected the device you care about

If you've done this, then we can move on to whether you are having issues in adding tiles in your dashboard....

1 Like

The issue is that dashboards display connectly i.e. show devices that had been added by selecting devices via hubitat dashboard configuration. Now when trying to add a new device, the configuration has no devices currently shown as selected.

So are you saying you have added the devices in the configuration screen I showed, but when you try to add a new tile in the dashboard you can't see any devices? Or you can't see the new device you added?

I guess what I am asking is, were you able to do steps 1,2 and 3 I outlined in my previous post, but have struggled to add a device to a dashboard as a tile?

When trying to add a new device, none of the previously added devices are shown as selected. Yet the dashboards do display as expected.

Hmmm, that does seem odd... Are you saying none of the previously selected devices selected appear in the dashboard configuration scren (accessed from the Apps screen in HE Admin page), or are you saying none of the devices are appearing in the list of devices when attempting to add a tile?

The first, previously added don't show as selected. I've tried multiple local backups, no change.

So in the Web UI you click on Apps, then click on the dashboard name under the "Hubitat Dashboard" app? Then in the screen that opens you don't see any devices in the "Choose Devices" list?

Correct. none of the devices are shown as selected even though they are displayed on dashboard for the oldest dashboards. For two DBs created recently(2.2.8/2.2.9), devices shown as selected...
Speculation: issue instroduced in either 2.2.8 or 2.2.9
I'll just add devices back.

Could you add some screenshots of the that are showing this? Ex.: Within the Hubitat Dashboard, of one of the problematic dashboards and of the “Add A Tile” screen from that same dashboard?

As they say, a picture is worth a thousand words - and I think it would help us help you figure out what is causing the issue, or if we think it might be something new.

I've already all devices to enable in DB. So going to DB configure is not going to demonstarte problem. Attach is new DB w no devices configured, same symptom for exisiting DBs


Okay, so you created a new dashboard and it has no devices - that is expected behaviour since at least 2.2.8.

Trying to understand the issue:

  • Are you expecting that when you create a new dashboard, the devices that were added in another one you had created previously will also appear in the new one?
  • Are devices that you added in a previously created dashboard disappearing? Ex.: If you add devices to the “New” dashboard, save then come back to this screen, they are no longer selected.

The latter, existing DBs, when selecting DB configuration; no devices are shown as selected....

Okay, so devices that were selected are no longer appearing when you come back. Do they all disappear, or are only specific devices disappearing? If specific, does there seem to be a pattern? Ex.: All Hub Mesh devices, or all door sensors, or all switches of a certain brand, etc.

All devices are missing. I don't have multiple hubs, hub mesh etc....

Okay, that sounds like it could be an issue that is over and above anything that I have seen and can deal with. I’ll tag @support in case there is something that they can do to help you with this.

Thank you

Yep this happened to me too when I went to add a device none of the dashboards were showing previously added devices in the tickboxes. So when I added the new device I wanted and saved, it saved as if none of the existing ones were selected any more, leading to a broken dashboard. I pretty much had to remake the selections, and did so by having two windows open one in the dashboard display itself to remind me what I wanted, and one with the settings.

But this happened apparently at one point and not before or since. When I went back into selection menu for the dashboards all the selections were as I had selected. So I assumed the glitch had come and gone in previous updates and was now fixed.

Download the Hubitat app