Device Firmware Updater Error

I'm trying to update my Zen 23 from 4.0 to 4.01. I obtained the firmware file from Zooz. I uploaded the .otz file to HE, started the update and received this error:

Bryan (@bcopeland), Iā€™m seeing a different error in the logs on my C-7 with 2.2.4.145 when trying to use the Device Firmware Updater:


Here is what I did:

(1) yesterday, updated the firmware on my ZEN16. Went well (except I had to exclude, reset, include the ZEN16 after update). I left the file in the firmware updater file manager, seems ok.

(2) tonight, uploaded firmware to update Aeotec Range Extender 7 (note that type of file is different from before). Tried to update, got errors above. Tried 3 times, got 3 errors, rebooted hub, tried again, got 4th error.

(3) here is what firmware updater file manager shows:

Zooz devices always require an exclude/include after a firmware update. I think I recall reading that they design their updates that way on purpose.

Can't help with the Aeotec, sorry.

S.

1 Like

fixed in next hot fix release

@672southmain

I have mostly aeotec devices and was going to see about upgrading the firmware. Can I ask where you got the firmware from and have you updated any aeotec nano switch / multi sensor with the firmware update utility ?

Thanks

Two places. The first place I have gone is to the Aeotec Support site:

All of the devices are listed, and, if you click on any device, you can see articles with links to firmware updates. But those aren't all of the places.

Apparently, there is a bit of a disconnect between Aeotec support and Aeotec engineering. Sometimes, a firmware update is "Released" but not entered onto the Aeotec support site. An example of this is the 1.02 firmware update for the Aeotec Range Extender 7 (which I have), fixing an indicator light bug discovered by Denny Page (@dennypage), who has written a nice user-contributed driver for the device. I have used that driver, but am not using it now on my C-7 because I am trying to keep everything as vanilla as possible while I nail the other remaining Aeotec issues with other devices. Denny Page provided a description of the issue in a README file on his GitHub repository:

Denny Page GitHub README

Aeotec Range Extender 7

This driver supports the Range Extender 7 manufactured by Aeotec.

Indicator not always working as expected...

Note that in firmware version 1.1, there is an unexpected behavior with the RE7. Following network inclusion, the indicator remains illuminated as expected. Double clicking the "action button" enables and disables the indicator as documented. However as soon as the illuminator status is queried (INDICATOR_GET) by the Refresh command, the device disables the indicator, and it can no longer be enabled by double clicking the action button. The indicator can only be re-enabled by an explicit set (INDICATOR_SET) done by the Configure command. Even once the indicators been enabled by the Configure command, if the indicator is subsequently disabled and re-enabled via the action button, the indicator will again be completely disabled as soon as a Refresh command is executed.

This issue is addressed in firmware 1.2, released September 2020.

Despite being "Released", this firmware does not seem to be available on the Aeotec support site. However, Denny Page provides a copy of that firmware update file in his GitHub repository for his RE7 driver.

ZW189_Range_Extender_7_US_A_V1_02_OTA.gbl

It's a very nice driver, lets you do range testing and a power level set for testing.
Denny Page GitHub repository

Simply FYI, Bryan Copeland (@bcopeland) and I have corresponded privately and my errors, reported upthread, with the Device Firmware Updater are apparently unrelated to the firmware file type (complete red herring) or device, but instead are due to the fact that I previously had updated a ZEN16 that subsequently was excluded, factory reset, and then included at a different Z-Wave node address, such that a previously-updated device is no longer available when a subsequent device is being updated. The workaround for this error is to remove the Device Firmware Updater app and add it back. Bryan Copeland says that the files will still be present for the File Manager when the Device Firmware Updater app is added back. I have full confidence that Bryan will have this fixed in a future hot fix update.

Sorry, no, I don't have those devices. However, there do appear to be updates for the Aeotec nano switch (you don't say which one you have):

https://aeotec.freshdesk.com/support/solutions/folders/6000225681

and for the multi sensor 6:

I am confident that you will be able to update them using the Device Firmware Updater app, even if the workaround, discussed above, is necessary.

1 Like

Getting back to the OP, I just updated to .148 and tried to do this firmware update again. It got to about 14% and then I noticed this error:

Edit 11/27 - Tried again today and saw this in the log: