[DEPRECATED] Tasmota 7.x/8.x firmware for Hubitat + Tuya, Sonoff and other drivers

@markus the only non wifi Tasmota device I am running is a Shelly 1. The current drivers can be found here. I use the Shelly Alarm driver (and so do others) so if we can bring this into your fold we would be sorted.


EDIT: honestly I would prefer it be on Tasmota anyways so I can isolate it on my NoT network rather than IoT.

Shouldn't be a problem, but I can't get in there, it requires a login.
I don't have any Shelly devices though.
Supporting Shelly Devices with Tasmota on them should be easy, and as for an alarm driver, that sounds like fun. Should get one of those alarms. But won't do it with a Shelly, they are very hard to get in China.

1 Like

I'll PM you the code for the alarm

1 Like

Thank you, your code is very nicely written!
Best of luck with your new job with Inovelli!


Thanks mate !

1 Like

Hi everyone!

I'm beginning to work with domotics and I'm setting up environments where I fell confident with the solutions to work it out how to work with them.

I've been watching this thread for a while and I'm really impressed with the work done with this Tasmota Hubitat integration - congratulations everyone, and, obviously, specially you @markus!

So, I'm experiencing some issues with a test setup I'm working with and I would like to request help to solve it.

I have the following environment setup regarding issues I'm experiencing:

a) Hubitat C5 - firmware running:
a.1) Sonoff RF Bridge driver (Tasmota - Sonoff RF Bridge (Parent)) with "Insanely verbose" debug option on
a.2) Sonoff (kind of ..) C50W Smoke detector driver (Tasmota - RF/IR Smoke Detector (Child)) also with "Insanely verbose" debug option on

b) Sonoff RF Bridge R2 v1.0 running:
b.1) Tasmota Hubitat 7.1.2 driver ver 0.9.2
b.2) RF firmware Portisch (RF-Bridge-EFM88B1-20181127.hex)

c) A Hubitat Bridge device
c.1) Current status info
c.2) Current state variables

d) A child device of the Bridge device
d.1) Current status info
d.2) Current state variables (none)

e) A very basic rule that will log a message when the smoke detector status turn to "detected"

Well, when I press the button on the smoke detector I got the following messages at Hubitat's log:

with no firing of the "detected" event.

I'm doing something wrong?

Thanks in advance!

I'm happy you like this implementation, and I love getting feedback!

I replied in the other thread, since this is a driver which will need a lot of discussion all by itself.


Just starting out with Hubitat this week and this is the first thing I am trying beyond the basics.

I have used Tuya-Convert then your latest firmware to flash a UK power strip with 3 sockets and USB, that all can be individually controlled. Can login to the Tasmota directly and have configured and it works correctly, and I can toggle the sockets and usb all correctly in Tasmota

Now need to connect it to HE using your thread. The issue I have is that when I try to install the Tasmota-connect app, when I go to save it, I get the error message "unexpected char: '#' @ line 70, column 17." tried deleting the # but it then gave another error?? What do I need to do to correct the error.

Once I have managed to load Tasmota connect can I load the generic driver with multi relay support ( tasmota-generic-pm-plug-parent-expanded), will that then be all I need.

Welcome to Hubitat! I’m on my phone on my way to bed, but use the RAW link and the import button instead of copy-paste. Also, the drivers and apps to use are the EXPANDED.
For a multi-port switch you will need to install both the parent and child driver. Tell me how it goes and if you still have issues I’ll try to help more tomorrow.

Making progress.

Got Tasmota-connect-expanded installed and working.
Installed the the tasmota-generic-pm-plug-parent/child-expanded drivers installed.
and its all working as expected.

Thanks a lot for this another thing now with local control.

Power strip has 3 sockets (that can be controlled individually) and a group of 4 USB's (that can be controlled as a group). I configured it as shown below.

But I also have another power strip which I would like to convert to Tasmota, but this one has 4 sockets and a group of 4 USB's. The issue I have is that the Parent driver only allows you to select 4 relays, but his would need 5?
Think its configuration will be something like this (but have not done it yet so can not confirm).
But it will need 5 child drivers to work and would appreciate your advice to get it to work also.

Again thanks a lot for this.

Yup, you guys were right. 2.4g

I upgraded to a new cable modem last week - after the tech left i set it up the same way as my last one - modem is not in bridge mode and is doing the DHCP for my wired & wireless. wifi is disabled on my modem and i have a netgear x8 R8500 AC5300 with leonardo (2.4) and leonardo (5g) ssid's.

Somehow the wifi on the router was re-enabled with bot 2.4 & 5g ssid's set to "leonardo 5g". I can only assume that this took place when i installed the ignite app on my phone, but to tell you the truth i have no idea.

My netgear was telling me today that the updated SP10's we 'wired' (huh?) well that was because they were hanging off the modem's 2.4g. Lesson learned.

I have three new & one old SP10 now upgraded to the 7.1.2 tasmota-hubitat so far and configured. i still haven't done any work on the HE side.

I have a new question. With sonoff-basic 6.5 these plugs reboot quickly and connect back to the wifi in 20 seconds or so. These new plugs with 7.1.2 always go into webserver mode, not just for three minutes, but more like 20-30 minutes. I attempted to modify WifiConfig parameter but didn't get any change.

1 Like

I modified my 2.4g setting to disable 20/40 MHz Coexistence and this has improved the connection time to my AP. This is new with v.7.1.2. I have been using these things for over six months with v.6.5 basic with no issues with the router setting.

It still appears that it defaults to to wificonfig = 2 because i am still getting at least a three minute delay:

2 = set Wi-Fi Manager as the current configuration tool and start Wi-Fi Manager (web server at for 3 minutes, then reboot and try to connect Wi-Fi network

@plumsden I've updated the driver, there is now support for up to 6 child devices. You only need to update the parent driver.

@steve.maddigan Great you got it sorted! It does sound like something is still not right with your Wifi settings:

I will also look at this some more later today when I'm back home.

1 Like

@jchurch Made a first version of the Distance sensor:
Sensor (Distance) (UNTESTED driver) - Import URL: RAW - Device Model Info

It requires some polishing, and some documentation. To get constant updates a rule need to be added to Tasmota:
Rule1 ON SR04#Distance DO status 8; endon
Rule1 1

This makes distance updates almost instant, BUT if all of that would be generating an event in Hubitat, we would not have a happy hub. Right now I only update if the change is more than 0.5cm... I also allow setting the decimal precision to minimize amount of updates...

1 Like

Sweet. I just need my sensors to arrive as they are lost in the post. I'll let you know they arrive as I have logged a request through postal service.

1 Like

Thanks Again @markus

Used the new tasmota-generic-pm-plug-parent-expanded and it works with the power strip with 4 sockets and usb, that I have just converted over to tasmota.

Also made an rflink a while ago might see if I can get it up and running sometime when I have got into this a little more.
Also you have drivers showing RF/IR in description, how is the IR implemented?

1 Like

Nice to hear:)

Looking forward to hearing about your progress with that. As far as I know only myself have tried that integration so far.

The child devices can be used with the IR parent device, just that I haven’t released the parent device drivers yet. Maybe in a few days if I find a few monents.

Sorry, what I was trying to say about IR, was what hardware does it use?

I have these with Tasmota:

The YTF one is really nice and stable. The other one is ok, but not as good.


@markus were you able to make any progress with the Tuya MCU? Can you clarify what the issues with the WF500D are.

I recently installed 2 in my basement and want to flash with Tuya. Perhaps I can be of assistance in resolving issues, just need to know what the problems are.

I suspect alot of issues can be resolved via the proper commands, found here:


Let me know what you need and how I can help.