[DEPRECATED] Echo Speaks

The Echo Speaks app itself. Not the Heroku app. I've removed the Heroku app and my
devices were never removed from HE.

I didn't remove the app or driver code. All my echo devices have disappeared.

Is it just me or is this app not behaving the same as it did before the recent cookie issue? My Echo Dots only announce sporadically (sometimes only 1, sometimes all or sometimes none). I've changed nothing other than updating the Heroku app.

I removed everything, app, driver and server and started over. Working well. I did need to re-add to the automations etc but it didn't take much time.

Works perfectly !! Thanks @tonesto7

1 Like

How do I upgrade from 2.4.0 app and driver to 2.5? Do I have to remove it all and do the install all over ?

Just copy the app and driver over the top of what you have already and save them bud. (remove all the existing text first)

I can't get this working again. I have uninstalled the app and started over. I set it up using the instructions and everything seemed to go OK but when I go back into Echo Speaks it doesn't show any of my Alex Dots and it says that I am not logged into Alexa except that it shows that I am logged in when looking down the page at the Log In Service Settings. Any ideas what I am doing wrong?

Here is the log

app:14132019-06-27 11:07:20.955 am errorgroovy.lang.MissingMethodException: No signature of method: com.hubitat.hub.executor.AppExecutor.error() is applicable for argument types: (org.codehaus.groovy.runtime.GStringImpl, groovy.lang.MissingMethodException) values: [sendMsg Push Exception:, groovy.lang.MissingMethodException: No signature of method: user_app_tonesto7_Echo_Speaks_388.sendNotificationEvent() is applicable for argument types: (java.lang.String) values: [Echo Speaks Amazon Login Issue: Amazon Cookie Has Expired or is Missing!!! Please login again using the Heroku Web Config page...]] Possible solutions: render(), getLog(), now(), every(), grep(), iterator() on line 1918 (cookieValidResp)

app:14132019-06-27 11:07:20.847 am infosendMsg: Message Skipped During Quiet Time (Echo Speaks Amazon Login Issue: Amazon Cookie Has Expired or is Missing!!! Please login again using the Heroku Web Config page...)

app:14132019-06-27 11:07:20.838 am warnAmazon Cookie Has Expired or is Missing!!! Please login again using the Heroku Web Config page...

app:14132019-06-27 11:07:20.833 am warnCookie Data has been cleared and Device Data Refreshes have been suspended...

app:14132019-06-27 11:07:20.776 am errorcookieValidResp Status: (401)

app:14132019-06-27 11:07:20.764 am errorgroovy.lang.MissingMethodException: No signature of method: com.hubitat.hub.executor.AppExecutor.error() is applicable for argument types: (java.lang.String, groovyx.net.http.ResponseParseException) values: [There was an errow while parsing the response: , groovyx.net.http.ResponseParseException: Unauthorized] Possible solutions: render(), getLog(), now(), every(), grep(), iterator() on line 1191 (updated)

app:14132019-06-27 11:07:20.324 am debugUpdated with settings: [autoRenameDevices:true, createTablets:false, createOtherDevices:false, optOutMetrics:false, createWHA:false, autoCreateDevices:true, sendMetricsNow:false, useHeroku:true, amazonDomain:amazon.ca, regionLocale:en-CA, resetCookies:false, resetService:false, bypassDeviceBlocks:false, cleanUpDevices:false]

app:14132019-06-27 11:07:13.866 am errorgroovy.lang.MissingMethodException: No signature of method: com.hubitat.hub.executor.AppExecutor.error() is applicable for argument types: (org.codehaus.groovy.runtime.GStringImpl, groovy.lang.MissingMethodException) values: [sendMsg Push Exception:, groovy.lang.MissingMethodException: No signature of method: user_app_tonesto7_Echo_Speaks_388.sendNotificationEvent() is applicable for argument types: (java.lang.String) values: [Echo Speaks Amazon Login Issue: Amazon Cookie Has Expired or is Missing!!! Please login again using the Heroku Web Config page...]] Possible solutions: render(), getLog(), now(), every(), grep(), iterator() on line 1918 (echoDevicesResponse)

app:14132019-06-27 11:07:13.760 am infosendMsg: Message Skipped During Quiet Time (Echo Speaks Amazon Login Issue: Amazon Cookie Has Expired or is Missing!!! Please login again using the Heroku Web Config page...)

app:14132019-06-27 11:07:13.757 am warnAmazon Cookie Has Expired or is Missing!!! Please login again using the Heroku Web Config page...

app:14132019-06-27 11:07:13.755 am warnCookie Data has been cleared and Device Data Refreshes have been suspended...

Since the update my Echo Spots aren't working at all and more frequently than before the other dots aren't working. I'm not seeing any new exceptions in the logs.

I believe it states right in the logs what the issue is and how to fix it :slight_smile:

I see that but I had just logged in and everything seems fine. It says that I am logged in on the Echo Speaks app page.

Something is out of sync. Try to perform a server redeploy. https://tonesto7.github.io/echo-speaks-docs/#/docs/support/redeployServer (Keep in mind the screenshots are for ST)

This is what I see when I click on the Amazon Login Page under Server Management.

I can try that again but I actually have done that about 4 or 5 times in the last 2 days. I finally uninstalled the app and started over and this is where I am at now.

I understand you are frustrated, but keep in mind this is playing middle man to 2 different platforms and trying to support multiple countries is very difficult. If Amazon uses a different value or changes something for one region it can screw up the whole process.

1 Like

I understand and I appreciate all the work you guys do with these integrations! Must be frustrating trying to keep up with constant changes with Amazon, etc. This is the log from Heroku. It looks like it is getting the cookie.

2019-06-27T15:54:39.062595+00:00 app[web.1]: localCookie:
2019-06-27T15:54:39.062598+00:00 app[web.1]: 'session-id=134-2801364-9286521; session-id-time=2192370878l; ubid-main=132-4852462-1683743; x-main=o@0FnxHotfN2tMDiyTQ4fb5DaA?Ixo9H; at-main=Atza|IwEBIGeGdZDqEXq8VEN-9l-4W7TjfwsVfTVyTo8KYweVdk3nBcB4RBqcHBOTbfOYZY3C_IM80RoWl4XwlBN-_6sQmi3TRHmenXBAJ0dY9U1scdCDBOU92ZyEYNk180bwSys6qG_bJT2_EyFCeTrXXw-Tq42lUFm5yTHrrZNquhAA_JR-Biu11zY36LDwmU3ZfpKSaIcABhP-6gMpxAd2yAb9RxLUtZX7rYYTnmSXv8GOZZEEbVmhD1RaIVaWIvpJjpHW5nxC0b0AnmNhdMIMUaJfO-rDViYeH-CFH_4j6bzHkkNjW1ov9KqTaypYckdRjnBDA_XTnEByGEE9UnsIy-bwTJxFBUbaozt7tqVHxVZnClNlqIUKghbHiOUUDku40BxMBppMkVlYx8UyPbAqMfgk9xjg9OVaPJ2Dabtqh7XroAQ4cyAzj8VEW5YKg5mZT1hsneY; sess-at-main=fvrNO6B2gP7FFnnavA1BU13Sbi/g1uvUuCZGN180HtY=; csrf=-2071927653',
2019-06-27T15:54:39.062601+00:00 app[web.1]: csrf: '-2071927653' }
2019-06-27T15:54:39.064798+00:00 app[web.1]: removing path
2019-06-27T15:54:39.065540+00:00 app[web.1]: 6-27-2019 - 3:54:39pm debug: Alexa Login Status: Login Successful
2019-06-27T15:54:39.066910+00:00 app[web.1]: 6-27-2019 - 3:54:39pm silly: Echo Speaks Alexa API is Actively Running at (IP: 172.19.39.114 | Port: 24103) | ProcessId: 4
2019-06-27T15:54:39.275890+00:00 app[web.1]: 6-27-2019 - 3:54:39pm info: ** ServerVersion Sent to Hubitat Cloud Endpoint Successfully! **
2019-06-27T15:54:43.094641+00:00 heroku[router]: at=info method=GET path="/config" host=echo-speaks-k9wy01phy.herokuapp.com request_id=6b50bb7f-fd31-423e-8ec8-5e3a9b80ad45 fwd="104.158.1.183" dyno=web.1 connect=2ms service=6ms status=304 bytes=348 protocol=https
2019-06-27T15:54:43.085961+00:00 app[web.1]: 6-27-2019 - 3:54:43pm debug: /config page requested
2019-06-27T15:54:43.278846+00:00 heroku[router]: at=info method=GET path="/configData" host=echo-speaks-k9wy01phy.herokuapp.com request_id=67e5040e-b7a5-44e8-8200-b9ceffd89f48 fwd="104.158.1.183" dyno=web.1 connect=1ms service=4ms status=200 bytes=766 protocol=https

No luck still ?

Not for me.

Sorry for not replying i've been on vacation for the last 4 days :expressionless:

Are you saying your isn't working now? or were you asking @pcgirl if she is still having issues?

This still isn't working for me. It shows that I am logged into Amazon but the app says that I am NOT logged in. I have cleared it and logged in again multiple times but it still won't recognize it.