[Deprecated] Amazon Alexa Text to Speech (TTS) v0.6.2 - Direct Integration (USA, Canada, UK, Italy, Australia, & Brazil)

That is strange. I wish we knew what was going on... :thinking:

Once again I was able to successfully log back into my Amazon account using @gabriele's Alexa-Cookie NodeJS server. I then copied the "Alexa cookie refresh options" into the App in HUbitat, clicked the "Force Refresh Now?" to on, and five minutes later everything is back to working again.

So, I know the Alexa-Cookie NodeJS server is capable of getting a cookie and sending it to Hubitat successfully. It just appears that after a few days, it cannot get another new cookie.

And 6 days later my automatic cookie refresh is broken again. :disappointed:

@gabriele - is yours still working? Or just the first time like mine? Any ideas on what is going on?

For now, I am going to go back to manually updating my cookie every 13-14 days... Not sure what else to do at this point.

I get the error that the cookie couldn’t be refreshed but mine continues to work. Very strange.

Don’t change anything if it works! :sunglasses:

1 Like

I've just come back home, mine it's still working and I don't have any failed cookie update notification.
Could you send me the logs if you start a refresh manually from the switch inside the app?

Do you want to see the Hubitat Live Logs? Or logs from the RPi?

The Hubitat Live Logs have no errors and show that the cookie was refreshed. However, the cookie returned appears to be invalid.

If I go through the entire process of re-logging into Alexa.amazon.com via the AlexaCookie NodeJS server, and then copy the 'options' data to my Hubitat App, and then force a refresh, 5 minutes later I have a valid cookie. 6-7 days later, when it tries to refresh the cookie automatically, there will be no errors in the Hubitat Live Logs, just a success message...however when a TTS message is attempted on any device, it throws an error. A new cookie solves the problem...

I've just checked mine and seems to be still working since around 20 days ago (when I wrote how I solved it).
Maybe it's something on Amazon side? If you have the same version and done the same steps, there is no reason why it shouldn't work..

interesting @ogiewon that copy request header isnt there in that list anymore..

Please try following the ReadMe directions with attention to detail once again.

1. Open Chrome and Login to alexa.amazon.com
2. Open the Chrome menu at the top-right of your browser window, then select Tools (More Tools) > Developer Tools (or click F12)
3. On top row of developer tools you will see several tabs: Elements, Console, Sources, Network, etc. Click Network.
4. Just below the tabs you will see a red circle, below that you will see a filter box, and below that you will see sub tabs: All, XHR, JS, etc. Click XHR
5. Click Smart Home in the left navigation
6. The developer tools XHR list should populate with several items, one called "featureaccess-v3", right-click on it and choose Copy, Copy Request Headers. This will place it into your clipboard.
7. Paste the cookie into the app

the screenshot is me right clicking "featureaccess-v3" and copy request headers isnt there.

Note sure what to tell you...:thinking: I just went through the process and it works fine for me. Are you sure you've selected "Smart Home" in the left navigation window?

Maybe try using Firefox instead if Chrome isn't working for you?

1 Like

yeah smart home, only has 2 skills active.
Tried .com and .com.au
Will try another browser.

Today I started getting the check cookier error. I've been playing around with it for a few hours even grabbing the cookie manually is no longer working... it successfully detects the echo devices, but any speech event fails and followed by the check cookie...

Are there any alternatives?

EDIT: I just switched to echo speaks which seems to be working

Same here. Not sure how to fix it.

I just installed my Alexa TTS Manager App on my development hub, copied and pasted in the Cookie (i.e. "Request Headers" that I copied via F12 in Chrome), selected my country, selected my Notification device, clicked next, selected all of my Echo devices, and clicked done. I then went to Devices, selected an Echo device, typed in "Testing" and clicked Speak. My Echo instantly responded as expected.

Not sure what's going on for other users...:thinking:

My automatically-fetched cookie started failing sometime yesterday or so too. Not sure how to troubleshoot that besides maybe starting over with my information in that (NodeJS, I think) app.

EDIT: I'm in the US, in case location is part of this.

I’m in the UK, for those of us having issues, location may hold a clue ...


My manually fetched cookie (via Chrome) works for several hours and then inexplicably stops working. If I replace it with another manually fetched cookie, it will work again for a few hours.

If I try to renew the cookie automatically, the logs indicate that the process worked, but I get an error when text is sent to any Echo.

Here's what the logs say:

I wish I had an answer for you. I have not gotten the Auto Cookie Refresh to behave correctly ever since Amazon made some changes on their end a few weeks back.

Your manual cookies only lasting a few hours seems strange. Is there any chance you're logging out of the browser session where you copied the cookie from? It is ok to close the tab with alexa.amazon.com in it, just don't select 'log out' on that tab. I just verified that the cookie I manually copied yesterday into this integration is still working fine today, about 22 hours later.

Some Options:

  • If you're running the latest 2.1.3 firmware, you could create some virtual contact sensors that can be used to trigger Alexa Routines to make her speak whatever static phrases you'd like.

  • Echo Speaks is another option, as it appears @tonesto7 is doing a very good job of staying on top of Amazon's back-end tweaks.

I just don't have the time or passion to play 'whack-a-mole'. If anyone else wants to, I am always happy to accept Pull Requests.

That's it!

Totally understand. And, in this case, the issue appears to be with the cookie recovered from AlexaCookiejs. Shame really - everything worked so well until Amazon made those changes a few weeks ago.

1 Like

Download the Hubitat app