Delete Two "Ghost Devices"

Do a shutdown from the SETTINGS page, then disconnect the AC plug and wait for a minute or two. Apply power and When things come back up, try the REMOVE button again.

I tried your suggestion @JoeJ. The procedure took me into a loop back to the conditions I reported in my original post. Thanks for the try!

If they have neighbors attached you won't be able to remove them. Now you can try taking the device offsite or you will need to use a z-wave stick paired as a secondary controller to remove them. This is an issue with the SiLabs SDK. The ghosts will cause issues with your mesh.

Post screenshots of the Z-Wave details. Either the whole thing or at least the two problem nodes that wont remove.

0x0A is probably not going to work from the hub since it is showing a neighbor.
0x0D should be removable.

Here are my instruction as posted to this guide: How To: Remove Z-Wave Ghosts (including using a UZB Stick)

Have the regular logs page open (not zwave logs) while doing this.

Shut down the hub and restart it to force restarting of the Z-Wave radio - this can help w/ghost issues:
-- a. Shut down your hub from the Settings menu.
-- b. Then pull the USB power plug (recommended to do at the wall connection, not at the hub as the hub connection can be a little fragile, at least on some C-7 hubs) to completely remove power from your hub after it's shut down.
-- c. Wait 30s
-- d. Plug the hub in again.

Using the hub's built-in ghost removal tools
Below is a detailed summary from @jtp10181 of best way to use the hubs built-in ghost removal tools. Try these tools first before trying Ghost removal with a UZB stick:

  • Click Refresh on the device ONCE, wait for the page to refresh. The Remove button should then appear. Click Remove ONCE. Again, wait. May want to have logs open while doing this as well.
  • Sometimes it takes multiple tries of the Refresh button to get the Remove button to appear. Try to be patient and NOT click Refresh furiously. If you start getting "Zwave busy" error messages in your logs, power down and reboot again.
  • It is common for it to take multiple tries at the Refresh/Remove buttons to remove a ghost, give it at least five or six attempts before assuming it's not going to work. Shutting down/restarting between successful removals can also help.

You can also use the Topology Map (red/blue grid) to see which other nodes those consider to be neighbors, you can post that as well if you want.


Dang, they see each other as neighbors. That's going to be hard to remove. Usually the only time you can remove from the hub is if the only neighbor is the hub itself.

Did you factory reset the devices manually? If not they are probably still paired to the hub. If the exclusion had worked the nodes would have been removed. You might be able to just plug them back in (near the hub if possible), and then exclude them to get rid of those nodes.

Tried to remove x0D six times as you describe. Here is what I found in the logs:

sys:12024-01-27 10:07:11.037 AMinfoFailed node 0D remove status: 0 SDK failure node is no longer in failed node list

sys:12024-01-27 10:07:04.574 AMinfoFailed node 0D remove status: 0 SDK failure node is no longer in failed node list

sys:12024-01-27 10:06:57.652 AMinfoFailed node 0D remove status: 0 SDK failure node is no longer in failed node list

sys:12024-01-27 10:06:50.391 AMinfoFailed node 0D remove status: 0 SDK failure node is no longer in failed node list

sys:12024-01-27 10:06:42.584 AMinfoFailed node 0D remove status: 0 SDK failure node is no longer in failed node list

sys:12024-01-27 10:06:32.344 AMinfoFailed node 0D remove status: 0 SDK failure node is no longer in failed node list

Yes, thats the error you get when there is a non-hub neighbor still showing.

I would try to plug the devices back in and excluding them again. You might get lucky and the nodes drop off.

I manually factory reset each of the plugin modules after excluding them from the hub. I currently have all of the plugin modules included once again to see if that helped. They are included as New devices having no impact on the failed nodes. This is as expected after the factory reset.

Yes that is unfortunate. You should not have factory reset them. Those two nodes were not excluded properly or the nodes would have been removed.

You have two choices, ignore them and they probably wont do any harm. Or get a USB Z-wave stick and force remove them with PC Controller (explained in that guide I linked above).

Honestly, for seasonal devices I either just unplug them and disable the device in HE or leave them plugged in year round if they are acting as repeaters. I never exclude them, I have never had any issues.

I am just starting out and do not have that many devices installed. I am willing to do a Full Reset of the Hubitat and reinstall my devices if this is a solution. I Do Not see "Advanced" in Red on the Diagnostics menu -- thus no access to Full Reset.

The diagnostic tool is slow to self update. You can use the endpoint HUB.IP/hub/cloud/updateDiagnosticTool to force it (it will spin for a while)

A full reset will wipe the entire hub. If you want to ONLY reset the z-wave radio, you can do that as well. Just be aware that the linked devices listed in the hubs devices list (not the zwave details) will still be there and you would need to rename the DNI on them manually to avoid conflicts. Resetting only the z-wave radio can cause a mess if you are not careful, which is why it is not usually recommended.

You might want to use those seasonal plugs as strategic repeaters for now, you will find out if you need them as you add more devices. The C7 has a weaker z-wave radio due to the internal antenna so well placed repeaters can help.

One last question -- I hope. Is a Full Reset a solution to the issue I am facing?

Sorry I did not answer that before. Yes a full reset would clear the entire hub including the z-wave and zigbee radio data. Any z-wave devices still paired to the hub when reset would need to be factory reset (or excluded) and then paired again.

There is also a warning on the full reset about subscription services (not sure if you have any), make sure you read it.

@greg1 You could also just reset z-wave by itself instead of the whole hub. Depending on your version of the platform it will be on the diagnostics page (port 8081) or on the z-wave details page.

Yes I understand this would not be as dramatic as a Full Reset. The problem is that I do not understand how to "rename the DNI on them to avoid conflicts". Please see @jtp10101 above.

You just go to each zwave device (in devices list) and click the edit button by the DNI. Add something to it like _OLD so it looks like this. That will prevent any new inclusions from taking that device entry and making a mess.


Once you include the device as a new node you can use Swap Apps or manually move your rules and whatnot to the new device, then remove the _OLD devices.

As you can see, it has potential to make a mess if not done correctly.

1 Like

Yes, except I have no "edit button by the DNI". I only have an edit button in the Status column. I checked the Settings for this page and there is no check box available (as there is for Status edit).

I understand your caution here -- "Use At Your Own Risk"!! If a Full Reset is the alternative, it might be worth a try.