Dead hub (presumably) and apparently expired hub protect?

We had a power blip last night, and when I tried to get the hub back up this morning, it didn't come online. I noticed that the light on the front isn't coming on at all. So, I guess it's dead? I tried a different power adapter and usb cable. Is there anything else I should try?

If it is dead, then is buying a new one my only option? Like is there any discount for replacements or anything?

Lastly, I was subscribed to the hub protect and remote admin bundle, but when I logged in today it wasn't showing as subscribed. I don't really understand how to see the history of subscriptions, so I'm not sure how to tell what happened. Did it expire and not renew for some reason? I'd just like to get a clear idea of what's going on before proceeding with anything. And if it is expired, then does that mean any backups I had under Hub Protect are gone?


Sorry to hear that. A power outage could cause the hub to die when the power is restored and the hub is not on a surge protector.

Regarding the subscription, please create a case by visiting the following page and we would be more than happy to further assist:

You can also send me a private message with your hub's MAC address (there is a sticker on the hub itself) to get the case started.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.