Days of Week Schedule Triggering Multiple Times (10x) at Set Time

I’m having an issue with a Days of Week schedule that is firing multiple times (10x) within hundredths of a second when the trigger time arrives. This is causing the actions to run all 10 times. Trying to figure out if I’ve done something wrong in this setup or this is a bug. Triggers and trigger logs are below. Also, take note that due to another issue, I have recently performed a soft reset, but this issue has persisted despite that reset.

Thanks!


I’m seeing similar. Go into rule, click done, should stop for a while. Bruce has posted that this is a bug with predicates that will be fixed in 2.3.0, now in beta.

Do you mean simply opening the rule and then clicking done to exit? I’ve gone into this rule MANY times trying to fix it, so if that’s what you mean, I don’t think that’s fixing it for me.

Yes. If you open the gear icon on the rule and scroll down to the bottom on a rule that has predicates, you will see a plethora of repeated items for the row trigCustoms. I saw a hundred or so, they kept adding each time the rule tried to trigger but did or didn’t because of the predicate. Hitting Done, for me, fixed the rule and cleared out all the repeated items, leaving only one set.

Your issue may be different than what I and some others saw. I’m not on the 2.3.0 beta program, but @bravenel has indicated that this has been fixed in 2.3.0 beta.

Yeah, nothing there for me, so might be something else… or the duplicates just haven’t been produced yet. I’m following the thread you provided, so I’ll keep an eye out for updates.

Thanks for your help.

I think this is what @672southmain is referring to.
Not sure if your issue is the same but I had over 200 scheduled jobs in one of my rules.

1 Like

Yep, add me to this list. Thanks for the trick on clearing them out...just going to have to remember to do that every few days.

1 Like

There is known bug concerning Predicate rules causing this problem. It is fixed in 2.3.0, now in beta, or at least in theory it is fixed. In the meantime, opening the rule and hitting Done clears out the schedule.

1 Like

Thanks, I’ll keep an eye out for the update and try clearing out the schedule in the meantime.

This solution doesn’t seem to be working for me. I did this 5 minutes prior to my 10am trigger, and still received multiples triggers. Hopefully the 2.3.0 update will do the trick.

I'm sorry. This is fixed in 2.3.0, now in beta, coming soon.

1 Like

It looks like I’m going to need to rebuild this app using 5.1.1.. can you confirm? After the 2.3.0 update, I’m still receiving multiple triggers. Event tried to clone. Is there any way to update this without rebuilding from scratch? Thanks!

I will investigate your specific setup...

Download the Hubitat app