Daylight Savings TIme, Periodic changing Time bug

Sorry for the confusing title :smiley:

I have a rule to feed my Cats every 6 hours starting at 1:30 am, so they get fed at 1:30, 7:30,1:30,7:30. Since cats don't know anything about DST, I wanted to move the trigger back this morning to start at 12:30.

When I edit the trigger and change it to 12:30,

Then click "Done" It is still showing the trigger at 1:30am

Any help is appreciated to get my cats fed on time!

I have tried:

  • rebooting
  • going to the device settings and saying update time from browser
  • Going to the device settings for Location/Timezone and clicking save for the location to refresh
  • Creating a new rule from scratch

Have you thought of using a periodic schedule instead, and set it to 30 minutes after the hour at 1, 7, 13 and 19? That would provide the same and I think would automatically adjust to the new time.

It is using periodic, just doing at number of hours after start time.

It wouldn't auto adjust I don't think because the hub time itself changes. During DST I want them fed at 1:30/7:30/1:30/7:30, when not DST (now) I want them fed at 12:30/6:30/12:30/6:30. Since I don't think it will auto adjust, that means it's more to change when time timezone changes (update 4 hours instead of 1)

How about setting two rules one with a predicate condition going from the start and end date of Daylight time, and theother for the dates of standard time with the relevant trigger for each?

Might work for not today, but that. Current problem is I can't set it to start at 12:30. When I say that is the start time, it somehow moves it to 1:30. If I set 11:30 it goes to 1:30, if I set it to 1:30 it goes to 1:30. So I literally can't set the time to start at 12:30 am right now

Please show the scheduled job from the rule's App Status page (gear icon).

Also, which time zone is selected in Localization settings page?


I had a similar behavior today

Rule hasn't run today

Please be specific. Looks like it ran every two hours, right? Please show the Scheduled Jobs from App Status page (gear icon). But that's from yesterday! Do you have two instances of that app installed?

No, just one instance; never ran today

Still need to see Scheduled Jobs.

Still not running

Please open the rule and hit Done. There's nothing wrong with that schedule. Not sure why it's not running. Do you have all logging on for the rule?

For the original issue, the rule was running, simply on the old time not the new one. This morning, it is correctly showing starting at 12:30, so it clearly has something to do with DST and how the rule is handling date/time on the specific day DST starts/ends (I recall having this issue last time but I rebooted and tried again the next day and thought I imagined it).

Looking at logs this AM, it appears to have started last night. Maybe a logging refresh issue ????