Day mode failed to disable HSM Night Alarm

This has worked fine all week until this morning. Per my screenshot I have the settings in HSM configured to disable on Day mode. I also mode manager installed with a rule to turn on day mode at 6:30am.

I woke up this morning and HSM was armed. Per the logs I manually enabled Night Mode and HSM performed Arm Night. At 6:30am day mode was enabled however HSM was never disarmed. I had to manually disarm HSM. I'm glad I checked because taking out the dog would have set off the alarm and woke everyone up.

Any ideas?

Can you show your hub events from around 6:30 am confirming that your system went into Day mode? You can do a search for "mode" and it should list only them. 6:30 am is a little early for day mode if you're controlling mode by the sun. Sunrise around here isn't until 7:45 this time of year. :slight_smile:

Yea this screenshot isn't easy to get via mobile so I had to resolve to the chromebook.

This happened again this morning. In this screenshot you can see that Day Mode did kick in at 6:30am however it failed to disarm the alarm. Per the dashboard at 7:10am HSM status showed it was still armed so I selected disarm. From my previous screenshot you can see that HSM is to disarm on Day mode.

HSM is not arming or disarming for any mode now. We left earlier today and with our presence sensors the mode changed to away. HSM is supposed to wait 5 minutes then arm to away however it never did. Roughly 30 minutes later I decided to check the alarm and mode was away and HSM was still disarmed. I had to arm it manually.

We got home and the alarm never disarmed. Presence sensors kicked the house into day mode but HSM never disarmed. I had to disarm manually.

Is there an alternative to HSM because it doesn't work with modes?

Last week I had to reinstall it because it wouldn't disable the alarm.

This is very odd. So it was working and then stopped? Could you look at the app status page, where the subscriptions are, and see if say there is a subscription to Location. It should be there. Other thing would be to open HSM and hit Done. That should refresh the subscriptions, and it might start working again.

None of this explains why it stopped working in the first place, although my suspicion lies with the subscription to location events getting messed up somehow. Not good. We will investigate. Thanks for surfacing this problem.

Please let me know if hitting Done fixes it. Easy to test by just manually changing the mode, and changing it back again -- to see if HSM does what it's supposed to. Very curious to know answer!

Just chiming in. I noticed my HSM not disaraming a with my presence recently as well. Even though other automations were triggering. I haven't had a chance to investigate so hadnt mentioned it. I will pay closer attention now that someone else has similar.

Will be watching this thread. Don't want to derail.

Could you also look at the subscriptions on the app status page, and open the app and hit Done. I need to know if hitting Done fixes it or not. We don't know why a subscription would get broken, if that is what is happening. Hard to tell.

One more thing: Could you post the portion of the app status page for HSM that shows subscriptions.

Hi @bravenel. It appears opening the HSM setting app and Modes app hitting done seems to have worked. I opened my dashboard and selected night mode and it armed HSM. Changed back to day mode and it disabled.

I will have to test it. When you say HSM subscription are you asking for a screenshot of the apps page?

Ok checked everything when I got home to make sure I was not crazy. (nevermind that my wife was here already.)

Logs of presence sensor arrival and other automations happening based on that.

Freshly loaded apps page.

App main page before clearing alerts.

after clearing alerts

subscriptions before disarm

subscriptions after disarm

subscriptions after pushing done in the HSM app

I know it is more than you asked for. But there it is. :slight_smile:

edit and a little more mode manger main page

and subscriptions

My issue was resolved by going to modes app, make change, save then change back and hit save. Also performed the same action on HSM.

I just want to chime in and say that I'm having the same issue. HSM is not arming or disarming based on mode changes. It was working here and there and as of yesterday just flat out stopped working. I also found this in the logs earlier:

I've had the same issue with HSM not disarming, both times with a mode change. Presence based arrival mode change and time based mode change.

Given your errors have you reached out to support? @bobbyD can make sure engineering is aware.

@danfox52, @ritchierich

Please open HSM and hit Done. And see if the problem persists.

We will also put out a hot fix release today to fix this problem. My bad.

1 Like

I did that, we'll see if it works.

@bravenel, I saw your post regarding the update to fix this. As always, we appreciate your fast responses and fixes.

So I am still having this issue. When I got home HSM did not disarm away mode. I had to manually disarm. My presence sensor did indeed report in. I have gone into HSM and pushed done.

Are you on the latest release? It's been 8 days since you last posted about this, so it's hard to know what you've got.


I thought I had been keeping up with the hot fixes. Looks like I got behind.
Hubitat Elevation™ Platform Version

Updating to today's hotfix now. Will follow back as life allows.