Dashboards Only Refresh Manually

This is a recent development for me. I have three Kindle Fire's that display three different dashboards. I am using Wallpanel instead of Fully Kiosk. My dashboards all work fine and display fine but they are not refreshing or updating. At first I thought it had to do with a hub update so I rolled back but that did not solve the problem. I tried going back to Fully on one of them but that did not make a difference either. I have also tried restarting my hub a couple times but that did not help either. The settings on my dashboards for refreshing are the default settings and nothing has changed there. I could sure use some suggestions for troubleshooting this. I can only trust my dashboards if I manually refresh them with the green check mark and then they are OK for a little while.

Have you tried this on another device other than the Kindle Fire? Mine are refreshing on iPhone and iPad Pro.

I have one Lenovo Android tab I can test on. Will give that a try but I need the Kindles to work and the mystery to me is that the have for a year or two prior to this and I did not change anything except switch from Fully Kiosk to Wallpanel. I will have to keep experimenting but was hopeful someone else had already experienced this and solved. I was also happening with a couple of Sharptools dashboards.

That’s why I suggested trying on a different type of device to isolate whether it’s a hub issue or Kindle Fire issue. It’s possible that something changed in one of the recent updates that affects browser interaction from the Kindle Fire. Interesting that it’s also happening with Sharptools.

I don’t see how it could be related to the recent security changes to prevent hub exposure to the WAN because you are able to load the dashboard initially but not auto refresh.

Have you verified that the device state is updating in your hub? eg. Directly from the Devices section of the Admin UI on your hub?

Edit: And what hub version are you on now? Reading through your post from a few days ago, it wasn't clear to me if rolling back to resolved the issue for you then or you meant that fixed it a previous time?

Thanks for responding Josh. Since the rollback did not resolve the issue as I thought I went ahead this morning and updated to most current software

Not sure I fully understand your question about device state. It seems to be any and all devices at different points in time, Example. I have a routine that sets Home mode at 5 am. On one kindle that is reflected correctly on the panel and on another it continues to show the system armed until I do a manual refresh. One panel will show a door locked while another (correctly) shows it unlocked. It is not consistent. Makes me wonder if some Kindle update caused this except no on else seems to be reporting so that seems unlikely. My in house wifi is a Google Mesh with strong signals throughout the house and no other issues.

Only things I can think of are some kind of battery / wifi optimisation settings on your tablets that may be breaking comm's back to the hub. This can sometimes be a per app setting as well, which could explain a change in behaviour when moving to a different app on the same device.

Perhaps you led me to the issue. Time will tell. I checked one of the offending Fire's and it had a feature called "Smart Suspend" which turns off the WiFi when you are not using the device. I turned that off and will see if that makes a difference. It was either turned on by a Fire update or it has been on all along and is not the issue. It certainly acts like it is losing WiFi and when I press the refresh button it "wakes up" and reconnects. Make sense. I will report back once I have an indication.


Quick update. 24 hours with Smart Suspend turned off on all three kindles and no issues so far. Encouraging. Also found this posting elsewhere that, while addressing a slightly different issue with the Kindle, might be another clue for someone who knows more about the technical aspects of this than me.


FINAL POST on this topic for me. Turing Smart Suspend off on all my Kindles solved the problem. No more issues with lost WIFI. One more reason to not like the updates Amazon forces on us unless we root the devices.