Dashboard Tile Opening but not Closing Garage Door (Control Tile)

I'm almost scared to ask this as it looks like there's been a lot of tension about the MyQ and MyQ Lite apps and garage door openers, etc. If my problem relates to all the prior discourse, just let me know and I'll go away. But it seems like my problem is more related to a dashboard tile function -- or not -- than to the MyQ control. I don't know enough to know.

I have a C-7 Hub, updated, with numerous devices that I've worked through many installation issues with. Got all working with a lot of research. Understand dashboards pretty well -- also notifications, apps, etc. I try to figure out myself -- lots of Googling.

My question...

I have a Liftmaster/MyQ controlled garage door opener. The MyQ iPhone app works fine -- I can open/close with the product app. Trying of course to integrate into Hubitat. I installed the Hubitat MyQLite app and adding my credentials. Given all I read, I was kind of surprised that I can actually OPEN and CLOSE the garage door from the devices COMMAND page. So, I assume -- perhaps wrongly -- that the MyQ Hubitat app is working for me even though it's not supported anymore apparently.

I have also successfully installed a separate Aeotec D/W sensor 7 Pro that reports on the open/close status of the door. All good there.

So I tried to do the next step (before trying to do any open/close conditional automation which I'll do when I'm comfortable that everything is working) to determine whether this indeed does work by creating a dashboard with a control tile to either OPEN or CLOSE the door using the device created by the MyQ Hubitat app.

The problem: When I created the garage control tile, and selected the device, I can OPEN the door using the control tile push from a fully-closed position. But, even though the tile does change state to show OPEN (red) -- I can't close it with a second push. When I push it -- it records the push -- and the tile changes state to a grey (full close I changed to red through template edit) -- so looks like it's closing -- but then doesn't finish and the time returns to red -- i.e., it remains open.

I'm thinking I'm doing something wrong in the dashboard tile selection or setup since I can open and close it from the device command page. It's not critical that I have a tile that allows me to control it -- but I always figure it's easier to test control there first before I move to automations.

Any assistance would be helpful, and my apologies if I poked a bear -- I did not intend to do so. Thanks in advance.

How do you have your dashboard tile set up? I'm using the "Garage (control)" template and it both opens and closes. It does take a few seconds before it responds, though, and the opener beeps a few times first. There's also a "Garage" template (no control) that just shows state.

1 Like

Oops.... I take it back. I'm using the "Door (control)" template, and it's working. But I tried "Garage (control)" and that worked fine, too.

Thanks for the response. I’m using the garage door control tile with the garage door device created by the myQ app. It’s got a nice little garage door icon, and as I said, I can open the door – but when I try to close it after, it reacts to the push on the icon — and the icon shows a state change — but doesn’t actually close the door and reverts to an open state shown on the tile.

And as a reminder, I can open and close the door with the control part of the actual device edit screen. :thinking:

Try “Door (control)” and see if that works. You can change the icon in the template using custom icon.

Thanks @jabecker! Tried the door control -- not garage control -- and got the same response. Could open the door but not close it. I'm thinking it's something in the app and perhaps there are more MyQ apps available -- I'm using the MyQ Lite but I think I saw somewhere there was another MyQ app that I may just start fresh. Would love to figure it out without using a relay spliced into the control wires, or, a remote of sorts.

Thanks for the help -- much appreciated!

Hello, I am having the exact same issue with being able to open and close the door throught the device page but only open through a tile on my dashboard. I was wonderring if you ever found a fix? Thanks.

Not yet -- although I haven't worked on it in a while -- but it is annoying. I'd like to setup an automation where when my contact is open it automatically shuts the door through MyQ. I'm sure there's a fix somewhere but perhaps because it's cloud based, there isn't. I know a lot of people use a relay spliced into the opener but I haven't tried to take that on, and it seems a bit Rube Goldberg to me for what should be a simple hook into a function that is available through the MyQ app.

I'll post here if I figure it out.

I would say the opposite is true, it is very backwards to send your info back and forth to the cloud multiple times just to open the door when you could just hook up two wires and control the door locally.

It has been a while since I used this integration, but I seem to remember the door will not close unless it sees the tilt sensor open first, and the door is not moving.

Did you use the "sensor" or "no-sensor" version of MyQ Hubitat app? Does the MyQ Hubitat app recognize your sensor? I know this works with a tilt sensor, but you are using a door/window contact sensor.

Are you using a tilt sensor on the door, and which version of this Hubitat app are you using? (sensor or non-sensor)?

Any errors in the logs?

So I went through the HPM and downloaded the MyQ lite code that came up, entered MyQ credentials, went through apps and added the MyQ lite option to my dashboard. Selected garage control. Then added the tile to my dashboard. I can click the tile to open the garage door and the status changes on the dashboard as it opens. Then the tile reverts to showing closed. I can however go into the device options page and both open and close it from there. Should I look for log errors on the device or the MyQ lite app. Thanks.

Again, which one? Sensor, or non-sensor version?

And do you have a tilt sensor? (NOT the MyQ one, it must be a standalone sensor) Does that tilt sensor read door open and close status correctly?

In the Hubitat Logs tab. Either the MyQ app might throw an error, or the Dashboard or even the MyQ device can produce errors. In any case, if you have Hubitat live logs open (preferably in a new browser tab or browser window), you can open and close the door and watch for any associated error messages.

Sorry, it’s the non sensor one and I don’t have any physical sensors on the door, it opens with just the tile on the dashboard. Thank about the tip on looking at the logs. I think that will help.

From memory, the Garage (control) tile won't work with this version. The Garage tile should. The trouble is, there is no way to know if the door is open and closed, you are just randomly mashing a button.

Tilt sensors don't have to be expensive, your experience will be a lot better with one. The Ecolink Tilt ( TILT-ZWAVE2-ECO) often goes on sale at Amazon for $10 if you watch. That same model are currently about $14 on Ebay.

Oh wow, that is a great price. So this sensor will tell me if the door is opened or closed but will not operate the door? Making sure I understand the premise.