Dashboard Thermostat Anomaly

While controlling my home's mini-split system with my Dew Point app, the dashboard virtual thermostat devices sometimes show odd results, such as this case where the mode is Off, but the device appears to be cooling. (The physical mini-splits are off) I've also had it where Mode=cool, with the runningMode= idle. My Dew Point app changes the device mode, but does not adjust the runningMode. In this case it changed from cool to off.

BTW DewPoint AC control rocks!

tagging @bravenel @mike.maxwell

Should you need more info about my system

Using indoor dew-point and node-red to control temperature/relative humidity - #51 by arnb

More examples
image
quickly followed by
image

You might was to show some screenshots of the device edit page as well... For the thermostat device, showing the current states at the time when you are seeing the various displays on the dashboard.

1 Like

Yes, this^

1 Like

As Requested. Virtual device and dashboard match. The physical minni-split is Off.

image

image

I believe the operatingState still being set as cooling will be your issue. Took me a bit to get my head around at first, but I expect it is to cater for auto mode and being able to be in probably one of 3 states, cooling, heating or idle.

I doubt it since my code does not set it.
If you have a copy of the Virtual Thermostat source code, take a look at where it sets the current operating state.

That's what I mean, or at least that is why it is displaying the way it is on the dashboard,. Why it is set to cooling I can't explain.

Do you have a link?

No it's not available, but I thought you may have a copy.

No, I've developed a separate one for Mitsubishi units. I'd check the off method to see if it sets the operating state to idle, which I expect is what it is meant to be.

My code is an app, setting a virtual thermostat with setThermostatMode("cool") or setThermostatMode("off")

The system virtual thermostat sets the thermostatOperatingState.

I've worked with virtual thermostats with my mini-split control app for many years, never had this issue, so I was surprised and confused about what my Dew Point app may be doing to cause this. Also went around the house a few times to see what the physical units were doing. The mini-split app follows mode, not the operating state so units are working as expected.

Oh, I get it now, you are using a built-in driver for the thermostat?

If so, I expect this will be one for @mike.maxwell and the team

Actually, what if you tried calling the off method instead of setThermostatMode(off)? Your approach should have worked, I expect, but this may get you a resolution for now

Yes, the Virtual Thermostat.

What does that look like?

Just:

off()

1 Like

when using the virtual thermostat one needs to set the temperature as well as the setpoints and desired operating states.
just like a real thermostat the operating state won't change unless there's a call for heating or cooling based on the thermostat temperature (that your app sets) and the setpoints.

That's done with Thermostat Scheduler app, dashboard, and when HSM status changes. the coolingSetpoint is currently set at 76.5F. Average Temperature app sets current temperature.

At this point it appears all my code works as expected and the physical mini-splits are following orders. It's only the Dashboard display and or Virtual Thermostat that occasionally goes awry.

Changed two lines of code for cool and off, and installed the code. Monitoring the dashboard. Without seeing the source code it's impossible to know if it matters. However it's got to be more efficient.

1 Like

Download the Hubitat app