Dashboard buttons not updating with Philips Hue Lights

I'm not exactly sure where this question belongs as it's a problem with my Dashboards but also a problem with the way my Philips Hue Lights turn on. I'm tagging @bertabcd1234 since I have my Philips Hue Lights imported into Hubitat through his CoCoHue community App.

The issues are these:

  1. Sometimes, when I turn on certain Philips Hue Lights, despite being at 100% brightness before they were turned off, they turn on not at 100% brightness but at minimal (1%?) brightness. This has the effect of making them look as if they are off when in fact they are on.

  2. When I turn them on or sometimes off, such as through Alexa, the dashboard tiles controlling these Hue lights, regardless of whether I use the dimmer tile or the color bulb title, does not update. For example, I turn the lights on, and the dimmer tile shows that it is at 100% brightness even though it is not. Or, I turn the light on, and the color bulb tile shows it is off.

  3. I can reproduce the problem when I turn off a given Hue device at 100%, then turn it back on. The dimmer button says it's on at 100%, but the light in actuality is at 1%.

Is there a fix for this? The only thing I can think of is that I have these Hue lights (they are in my kitchen) set to turn on with scene "Concentrate" whenever other Kitchen lights turn on, but I don't know why that would cause this problem....

What version of CoCoHue are you using, what is your polling interval set to (in the app), and if you're using v4 beta, do you have push/SSE enabled?

The polling is disabled, now that you mention it... I think I did that once because you had suggested it. Is that the problem and should I put it back on 1 min or something?

I'm not sure how to find the version of CoCoHue that I'm using but I think HPM is updating it periodically. I just now checked and HPM did not have any updates.

HPM won't get the beta (unless you turned that option on, and even then I'm not sure it will actually get this--manual install is my recommendation for the beta). Without polling enabled, you'll never get status updates from the Bridge for any changes made outside of Hubitat or anything from scene activation, unless you have the "refresh" option enabled for that particular scene (check the Hubitat device page) and it is also activated from Hubitat; or unless you manually refresh the Bridge device or do so via some other means at some point.

The polling interval is up to you and your specific needs. I think most people find 1 minute to be a reasonable starting point, and it is the default.

The beta--which I will eventually polish up into a production release--does support instant status updates from the v2 or later Hue Bridge with recent firmware via the new/v2 Hue API. I'd still recommend keeping polling enabled in this case (it still seems to fail on rare occasion; Hue or Hubitat issue, I'm not sure), but users might feel more comfortable lowering the interval.

So I enabled polling at 1 minute yet... I still find that many Philips Hue devices (mostly the light strips in this case) turn on at minimal illumination when I turn them on with Alexa working through Hubitat.

The only exception is if I turn on a specific scene, then it will turn on at whatever illumination is programmed into the scene.

Alexa will not necessarily turn them on to 100%, just to the last level (unless you say so). So the next question is: what was their last level? Do you have other apps that could be acting on these, like Lights on Motion Plus with dimming? What does "Current States" on the device page report for level, particularly at or just before the time in question? CoCoHue doesn't send a level with an "on" command, just the on itself, but the reported level should be accurate from the API.

Actually, I thought of something else, too. You don't happen to have any of the non-recommend transition-time preferences like "off transition time" selected, do you? If so, change those back to the default and see if it helps. They have been removed from the beta due to problems some had with them (and in one release, the default was set to an unintended value, not what the UI said was--and should have been--the default).

To answer your questions, it's not turning them on to the last level. I just tested this - turned on scene "Bright" in my study room which has the Philips strips at 100%, then turned it off without dimming them first. Then turned on the lights again without turning on the scene specifically, and once again it turned at minimum illumination.

I'm not sure what you are referring to by transition-time preferences. Is that something set in the CoCoHue app?

Not the app, the driver, so the device page for each device (light or group) in question.

I'm not sure how you're turning them off (or on), but if it's not being turned off from CoCoHue, the above -- a total guess since I don't have any other information to go on -- would not be applicable. But if you are turning the lights off from Hubitat, I'd check this preference since it sounds like it might be related. (Where the bulbs are turned on from after wouldn't matter, at least as far as I've seen so far.)

I'm turning them on and off with my Dashboard and with Alexa.

Now, I've created a workaround with rules that basically set them to 100% whenever the appropriate group/light is turned on. But I'm not sure if this will work when, for example, I turn on a scene that is supposed to have less than 100% brightness by default.

CoCoHue 4, now out of beta, addresses the issue with the odd behavior (on the Hue side) for some transition time preferences, which have now been removed. As long as you turn them off with "Off," the issue with unexpected levels after "On" should no longer happen.

If you want to stay on 3.x, you can just make sure the preference is set to "Hue default (do not specify)" for "Off transition time" (or all of the transition times if you prefer, but I think this was the problematic one). Preference Manager can help you set multiple at the same time if that's easier than going to every bulb device (groups never had this option).

I can get this just by using Hubitat Package Manager to update, right?

Yep!

It looks like the new update did not work. I specifically made it a point to open each instance of the CoCoHue app and click "done" as instructed. But turning on Hue lights with Alexa/Hubitat continues to start off with lights at minimal illumination, despite the fact that they at much higher brightness before being turned off.

Can you enable debug logs and show me what commands are being sent when the bulb is being turned on (and preferably off before that)?

Download the Hubitat app