Dashboard button produces "button null was pushed" event and no switch activity

I have a super simple setup right now: one Hubitat C-5 and one Inovelli Red Z-wave switch. I have one "Simple Automation Rule" to drive the switch on a dusk/dawn schedule. It works fine. I have no reason to think the connection to the switch is flaky.

Today I tried making my first Dashboard and I let the system set up default options. This included one button tile for the Inovelli switch.


The button doesn't do anything, though. So, either the automatic setup doesn't do all the steps needed to make a working button... or I am mistaken about what a Dashboard is supposed to do.

Edit with solution: there are 2 problems with the automatically generated dashboard tile.

  • The system picked a "button" template for the switch but that will not work for a light switch. Choose the "switch" template.
  • The "button null" log message is because the Button Number field is blank by default.

In other words, do not trust the Auto-Fill to produce working controls.

in your dashboard settings is this ticked?
If it is. Turn it off.

Also, your perimeter lights aren't a button unless you've created a virtual button. You need to choose what the actual device is. Inovelli red would be a dimmer or a switch. You have to choose according to the device capabilities. (reds may have a few more options)

For example. My ge/jasco dimmer switch is either a dimmer or a switch (on/off). I can use either depending on how I wish to control it.
A multisensor has the ability to be a temperature sensor, motion sensor, lux sensor, humidity sensor. You can choose one of those formats of type, but not a button.

I must be dense but I cannot find that "use all your devices" switch you mentioned anywhere.

your perimeter lights aren't a button unless you've created a virtual button

All I know is I did New Dashboard, selected "Auto Fill" and got this result with a "button" tile for the device.


I will check out the thread you linked, thanks.

OK, adding a value to this field fixes the "null" error in the log. However, the physical switch does not respond.


I created a new button for the device from scratch, with an ID number, and the physical switch still does not respond.

If this tile configuration is not adequate to create a button for a switch, what else do I need to do?

Ah hah. The problem is it needed to be a "switch" not a "button." I will update my first post for anyone else searching for the same problem.

As I explained above.
Glad you worked it out. We all take different paths sometimes to get to the same conclusion.

The fact that the system offered auto-configuration which was not actually useful was misleading.

YES! Very much. I agree 100% on that. We assume that what it chose was correct. And more times than not, it is correct, but I think that because the Inovelli Red is a unique bird, it confuses the processing of the discovery on the button. Because it can be configured in so many ways.
So the main thing to take away from this experience is to verify what type of dashboard function you are choosing for the device. Always has to be something within the scope of the ability of said device.

(Wow .. I must be getting better at this. I was able to directly explain my point) :grin:

On your other question, when you set up the dash, you have an option to choose all. Don't choose it if it's there. I had heard that it was eliminated in firmware updates, so it might not be there anymore. My version has it, but I'm on a C4 hub. When given the option, only expose what you intend to use for each dashboard. Always remove dead tiles. This is the number one cause of trouble with dashboards.
Also, make sure that if you're on your home network, you're using the local link and not the cloud.

1 Like