Custom Command For Thermostat


#1

Hey guys,

I am new to Hubitat. Prior to this I had a Vera controller. When I setup my thermostat I had to set it up as a generic Z-wave thermostat. I would like to be able to change the energy mode of the thermostat to the energy savings mode. The variable in the thermostat I would change was "EnergyModeTarget" and I changed the value of it to "EnergySavingsMode." Could someone help me do this with Rule machine?

Thank you


#2

Like your title says you'll have to make a custom command.
Then run that command in a rule.

Here's a video about making custom commands. It's not yours but actuator might still work for you.


#3

You can't do a custom RM command for a parameter/command that doesn't already exist in the driver. And that command is definitely not in the Generic Z-Wave Thermostat driver. Custom commands in RM are only for commands that a device/driver already supports, but RM doesn't expose by default.

So you are out of luck unless there is a device handler that has that feature for that thermostat. The good news, is there may be a custom driver for it... Or one that could be made.

What thermostat make/model is it?


#4

Thank you very much. The video is a good start. I don't think that will do what I need. Like Jason said, I think I need a different driver that has the parameter I need.


#5

Thank you Jason. The thermostat I have is the RCS TZ45HR.


#6

Do you know specifically what DTH / device handler you used in ST? The quickest path may be converting that one to HE.


#7

I am not sure if this helps but, this is the command I used in Vera:
luup.call_action("urn:upnp-org:serviceId:HVAC_UserOperatingMode1", "SetEnergyModeTarget", {NewModeTarget = "EnergySavingsMode"}, 139)

In Vera it was Service ID: urn:upnp-org:serviceId:HVAC_UserOperatingMode1
The variable was: EnergyModeTarget
The value: "EnergySavingsMode"

To change it back to the normal mode the value changes to "Normal".

Instead of using schedules I would have that ran when I armed my alarm.

Thank you


#8

Forgot you were on Vera and not ST, sorry. That doesn't help me, but it might help someone else that is more versed in Vera luup. I used Vera for a while, but it has been too long.

The path of least resistance is to find either a SmartThings device handler that can do it, or find the actual zwave parameter used to set that setting - and get it added to a thermostat driver (that isn't that hard once you know what parameter/command it is).

Because that thermostat is so old, on a quick search I can't even find the zwave configuration parameter guide anywhere. So your best bet may be to find a ST driver that does what you need...

Sorry I can't help more.


#9

Thank you for your help. I don't know if makes a difference but, I just went through the live log then changed the mode on my thermostat to away then back to home and found this:

dev:362019-02-02 11:52:02.015 am infoThermostat coolingSetpoint is 80°F
dev:362019-02-02 11:52:02.008 am infoThermostat heatingSetpoint is 73°F
dev:362019-02-02 11:52:01.934 am debugignore: ConfigurationReport(configurationValue:[0], parameterNumber:25, size:1)

dev:362019-02-02 11:52:42.115 am infoThermostat coolingSetpoint is 80°F
dev:362019-02-02 11:52:42.107 am infoThermostat heatingSetpoint is 62°F
dev:362019-02-02 11:52:41.521 am debugignore: ConfigurationReport(configurationValue:[2], parameterNumber:25, size:1)

I wonder if it is just setting parameter #25 to a value of 2 or 0. Woudl this be something that needs to be added to the driver?


#10

@Mikelk19
Maybe this sheds some more light on it?
Maybe I'm just floundering.
I used fan mode instead.

https://share.icloud.com/photos/0fh9CkddrxQpjKiUUTY1RlWrg


#11

Thank you Keith,

Unfortunately, since the driver does not include the "EnergySavingsMode" variable I am not able to change that mode to "away."


#12

That'll do it then.
Maybe see if there's a SmartThings driver?


#13

Thank you,

I will take a look if I can find one.