Corrupted Device?

I have a Zooz micro RGBW dimmer that has been installed and working for a few months. Now I tried adding a Zooz ZEN17 to my zwave network. When I ran the inclusion, for whatever reason, instead of the ZEN17 being added, what it seemed to do is Re-Add the micro RGBW. I forget exactly what happened but I think the new device that I added, I had to manually select ZEN17 as device type, and then I realized that my existing RGBW dimmer was no longer there, and, the new ZEN17 actually wasn't included.
What has happened as a result of all this is that my Zooz RGBW dimmer has extra child devices (for a ZEN17). I renamed it back to its original name and it still works, but I'd like to get rid of these child devices.
Unpairing the device from the network and starting over is my least favorite option because I'd have to crawl in a crawl space.... is there any other way to fix this?

Can you post your entire z-wave details page?

Change the driver to DEVICE and click save. Click ALL of the deletes on the page, then change back to the proper driver and click save, then click CONFIGURE.

changing the device type to "device" didn't seem to expose the delete boxes:

nevermind I see it, its on the device page, Delete All Child

1 Like

So I got rid of all the child devices, but when I switched back to the Zooz RGBW driver the child devices haven't been repopulated yet. But for the way I'm using it, the on/off and dimmer still work so in my case it doesn't really matter. Thank you for the quick easy fix, you saved me a crawl in the dungeon!

Did you click Configure?

1 Like

Yes a few times. It's strange because yes, clicking config, save and refreshing the device should definitely repopulate the child devices.

OK, it took a few device changes but it's back. Switched it back to Device, then back to Zooz RGBW and this time after a few reloads the correct child devices were repopulated. Big thumbs up!

1 Like

When the device checked in it would have eventually done it.