Corrupt Database

In the last couple of months I have migrated from the C8 to the C8 pro hub which I believed was successful at the time as everything seems to be working. However I have been unable to do any updates in the usual way to the new hub due to a corrupt database.

I have tried previous solutions from the forums, including safe mode, backing up locally, performing a soft reset, unplugging power cable and restoring the local backup.

The only way I have found to update the hub which isn’t ideal is to do a local backup then a soft reset and then do the update before restoring the local backup.

I wondered if somebody could take a look @support_team from the Hubitat Support team.

Currently running version:
New version available:

Many thanks,

Is there an error or something? How do you know it is a corrupted database causing the problem?

1 Like

Also, is supposed to fix this logging issue but possibly you have some lingering logs taking up space on the hub. Have you tried to do the soft reset with the logs purge as indicated in these instructions?


Thanks for the reply. Yes there is. The corrupt database error message is displayed after it has tried to update. The update process will reach to a downloading percentage of no more than 45% then shows its verifying download, then download failed and then the corrupt database message. This number seems to fluctuate between 20 and 45%. The whole downloading process is extremely slow too, infact its currently bombed out at 43% and taken 20 minutes.

Ive also tried a soft reset with and without logs purge selected.

Ok for the slow download, are you on Ethernet or Wifi? If ethernet go into your Settings > Network setup and change the ethernet speed, if its on 100 set to Auto, if on Auto set to 100. Then reboot for good measure.

Another thing you could try is these steps:
The revert to 2.3.7 is in the advanced menu in the diag tool.

Followed by the soft reset with the logs purge if needed (as instructed in that post).

You could also try updating using the diagnostic tool:

If you still cannot update after that then use the diagnostic tool to update. First use the Download Latest button, then use the Restore Previous... button (it can update as well.

Once you are updated I would do a reboot, click advanced then rebuild database and purge logs.

I think once you get updated to 2.3.9, and then do a reboot with a database rebuild and clearing the logs, that should get you back to normal.


Ok these are the steps i have taken.
Changed network to auto
Reverted back to
Soft reset with clear post logs ticked
Download latest from diagnostic menu
Restore previous
Restore database backup locally
Reboot with database rebuild & cleaning logs selected.

This is now updated to version however I am not sure if i missed the section for restoring the database after a soft reset earlier but basically the update was achieved with no database present. Which is exactly how I was able to update previously. The proof will be in the pudding when the next update is available and I can try an update with my database loaded. Thanks for your help.

1 Like

Looks like after you reverted to 2.3.7 you did a soft reset and then did not restore afterwards? So yes the database may have been wiped when you updated. But at least it got you updated and hopefully the download went quicker now.

Also, there was a database engine change in 2.3.8 which moved the database file to a new location in the filesystem as well. When I was testing out something else during beta testing for 2.3.9 and went back to 2.3.7 then updated again it lost track of my database as well and it was like the hub was wiped out, had to restore from a backup. You may have run into the same issue. @gopher.ny did you ever get a chance to look into this? Going from 2.3.7 -> 2.3.9 may cause the hub to appear reset.

There should be some new minor updates coming soon, so you will be able to test if future updates work and let us know if that fixed it.


Will do, fingers crossed

1 Like

I had the same trouble when I tried to use another power source than not the original one...

1 Like

I just tried to update to the latest version but it still does exactly the same as it did before and bombs out around 40%.

I also tried reverting back to the earliest version available ( and followed my previous steps with the exemption of restoring the database after a soft reset, but this failed too.

I have now updated to the latest version by doing a soft reset, update then restore local backup just as i have been able to do so before.

Regarding the power, Im using the same lead and adapter that I used with the C8 which worked with no issues and for good measure I tried my old C7 cable and adapter and this didn't work either.

That fact that the download stalls out and then after that it says the database is corrupt leads me to believe that for some reason the hubs file system storage is filling up. That has been the case in the past when the storage gets full it will start saying the DB is corrupted.

Do you have hub protect? A Full Reset might fix it for good but I would only do that under guidance from support, as it can mess up the subscriptions.

I would either open a support ticket:
Or you can send a PM to @support_team

1 Like

Unfortunately I dont have hub protect. I have just sent a PM to @support_team