Correct backup download filename

I assume this is the best place to put a bug report. I'd like to request that you fix the file naming convention for backup downloads. When I download a backup before updating my hub, I always get a backup file named "Home_2027-08-02_2.2.5.131.lzf". This filename is used regardless of the actual date and regardless of the actual current Hubitat version I'm running. This is a minor issue, but it's slightly annoying to have to change the filename every time I do the backup.


Odd, I just tried it on my two hubs (C5 and C7) and I am not seeing that behavior. And previous backups don't show this either.

What does your Current Hub Time show if you go to Settings menu, Hub Details? I bet your time/date is not correct.


The hub time/date is correct in settings. Also, this only happens to backups I create and download. Normal backup files are named properly.

Is your lat/long correct as well? Strange. I just did one myself and it saved the correct date in the file name. Update to and see if it continues... You can always roll back if it does.

1 Like

Are you really on platform version 2.2.5 as this filename suggests? I do recall a problem with backups from this particular screen a while back that I believe wad fixed. This platform version is quite old, and if it's really what you have (check Settings > Hub Details if you're not sure), I'd suggest updating as @rlithgow1 did.


Thanks, guys. My lat/long are correct, and I already updated to

So does your OS warn you that you have a filename by that name already? I have never encountered this problem.

1 Like

Database corruption???

Yup, Windows adds "(1)", etc. after the name automatically.

So you're on but it's till saving the file names as as 2.2.5 on top of the 2027 date? Now that certainly is strange. I'd give a soft reset a whirl. I mean it wouldn't hurt. When you do though, certainly download the latest version of your DB to your local pc and use that for restoring when prompted.

1 Like

Can you try this after clearing your browser cache? Or from an incognito/private browser window?


I had a similar issue with my C3 dev hub a year or so ago. The hub time was way off like the OP’s 2027 year. Not sure what cause the crazy time setting.

When you download the “latest” backup it gets the latest time stamp which 2027 is much later than current time so it always grabbed that backup.

I ended up resetting this hub since it was my dev hub as @gopher.ny didn’t have any ideas at the time to resolve it. Maybe he has some ideas now.

Look at the backup list in Settings - Backup and restore. You should be able to delete backup from there, there's got to be a Delete button to the right of it.

That did it! I deleted the last backup in the list (with the 2027 date) and had the system create and download a new backup. That one came through with the correct date and version number. Not sure why it worked, but it fixed the issue. Thanks!