Controlling scenes

I’m fairly new to Hubitat, but have figured a lot of things out already. Have basic rules moving well and a number of devices set up- zigbee, z-wave, lutron, and more I have a good dashboard going. But as I move into creating scenes and automating them, I’ve run into some trouble…

How can I control a scene on my dashboard? I see no options for adding a tile that works with a scene.

And I cannot get the Alexa skill to recognize or discover my Hubitat scenes. Any advice?

I do see my scenes listed within the device list as scene activators. Perhaps I need to give them each a network ID number or enable Hub Mesh?

There is a scene template you can use for a tile in a dashboard, or you can use a switch template. There are probably other options as well.

1 Like

Thanks. But I can’t add my scenes as a device in the tile adding menu. I only see my physical devices listed.

When a Scene is created using the built-in Hubitat "Groups and Scenes" app, a new 'Scene Activator' device will be created. This device can be shared with Amazon Alexa as a "Switch" device, which can then be turned 'on' by Alexa in order to activate the scene.

For a Dashboard, simply add the Scene Activator device, and then add either a Button Tile, a Switch Tile, or a Scene Tile (all shown below as an example). The Button Tile is simply sending the Scene Activator a command to push Button "1", while the Switch Tile can be used to turn on the scene, and will show if that Scene is currently set correctly. Changing any device within that scene will cause the switch to turn off.

2 Likes

Go back into your hub's list of Apps, then select the Dashboard App you'd like to add the scene to. You will then be able to add the Scene Activator device to the list of allowed devices for the dashboard, and then click Done. Now, open the dashboard and add the tile.

2 Likes

Of course. I forgot that step to add devices to a specific app or dashboard first. And thanks for all the detail. It’s all working great now!

1 Like

I'm a big fan of HE and have tons of automation via WebCore running and a fair amount of zigbee, zwave a very few wifi devices.

However, from time to time and lately more my scenes will fail to set two or three of my zigbee lights to the correct level, rgb, or CT settings. But, when I look at the logs it shows those commands sent and in the Groups/Scenes app it shows that scene as 'Activated'.

I know the most common cause is zigbee mesh communication. But I have switch channels over and over. Either the problem isn't consistent enough or its some other cause.

Any suggestions or help would be most appreciated.

Thanks.

I'd suggest setting up a separate topic for your issue, this one related primarily to how to configure control of a scene on a dashboard.

And you are most likely on the right track, metering of commands may be something to consider.

1 Like

Download the Hubitat app