Controlling Pioneer AVR Input via RM

My Pioneer VSX-32 is listed under Devices and I'm able to control it via the Hubitat UI.

How do I change the input via RM? It isn't listed when I select 'Control Music Player.' My Sonos device are listed.

Try selecting “Actuator” instead of “Control Music Player”. You may also need to tell it to “run custom action” to be able to select the “input” command.

1 Like

Wow, I would have never figured that out. Thank you.

Now, how to I use a variable to set the input?

I have a rule that captures the current input to a global variable and changes the input for an announcement. I then want to reset the input to its value prior to the announcement.

1 Like

I don’t know how this device works, but my guess would be that once you selected the Pioneer device, you would set the command’s parameter to the string variable as shown in the example below (for a different device...).

Let me know if it works!

Every time I click on Actions to edit them...

image

I created a clone of the rule but is also errors out.

This happens sometimes, especially if you change too many things back and forth or back out of the app. You will need to re-create it again from scratch.

1 Like

Looks like it was a type matching error not handled gracefully.

1 Like

Ah! Interesting. I never saw that before. Glad you were able to figure it out!

How do I power on the AVR if it is turned off?

There isn't an power on/off option under Custom Actions->Actuator or Control Music Player.

If there is no on/off option, it is more difficult... How do you power it on/off otherwise? With an IR/RF remotr?

This may be a long shot, but does your Smart TV connected to this work with HE? I turn my 'dumb' Onkyo on/off by turning on/off my Sony TV which has an HE driver. The tv is connected CEC via the HDMI and it syncs On/Off/Mute/Volume between the amp and TV.

There are community Samsung and Sony HE drivers that may work, or there are IR bridges like @Sebastien is suggesting. I've got one flashed with Tasmota that works with HE, but I'm not using it now since my Sony TV is doing the trick. Good Luck

1 Like

Good suggestion, thank you. I'll check it out.

I found power on/off under Custom-Actions->Actuator (was out of view).

Q: Do I need to provide a parameter or just 'Select custom command' = on?
A: Per the RS-232C & IP Commands for Custom Integration, I need to send a 0 (zero).

Appears I have found a bug?

Why do you have a Parameter number of value 0 with the On command?

Try it without setting a parameter to the On command and see if it works.

When testing previously, I thought it hadn't worked without a parameter but I must have been mistaken.

It's working without a parameter; thank you.

1 Like