Controlling GE/Honeywell Z-Wave Plus Dimmers is Unreliable

I have a long standing problem with my GE/Honeywell Z-wave Plus dimmer switches where they sometimes won't turn off or on when commanded. I have two GE 14294 dimmers and four Honeywell 39351 dimmers. I'm under the impression that the GE and Honeywell dimmers are identical and both made by Jasco. I also have an Inovelli NZW31 dimmer, Homeseer HS-WD200+ dimmers, Honeywell 39348 switches, an Inovelli NZ30 switch, GE 26933 motion dimmers, and GE 26931 motion switches in my house. All those that I mentioned work fine.

I've ruled out problems with automations (although I think rules that turn off/on alot of lights make it worse). The problem exists even when controlling the dimmers manually from their device page using the on/off command buttons. When control of a light fails, as in clicking the command to turn the light off, "switch" will equal "off" under the "Current States" section even though the physical light is still on. What is really weird is I have the physical switch's blue indicator light set to turn on when the dimmer is off. When the control fails, the blue indicator is turned on (agreeing with the current states section.) So the actual dimmer must really think the light is turned off, even though the physical light is still turned on! Once it gets it a failed state, clicking the off command again rarely has an effect, but occasionally it will really turn off the light. I have found that following a set level = 0 after a failed off command will usually turn off the physical light.

I don't think its a range or interference issue because these dimmers are throughout the house and many are adjacent to the other types of switches/dimmers that always work. On most of the dimmers I'm using JasonJoel's GE Z-Wave Plus Dimmer v1.8.0, but I've also tried the latest 2.3.0 and Hubitat's stock Generic Z-Wave Dimmer driver. All the drivers work the same. I'm currently running v2.1.5.124 of Hubitat. I think I've seen this problem in all the other Hubitat versions.

Has anyone else seen this problem with their GE/Honeywell dimmers? Anyone have any ideas as what could be the problem?

I just tried creating a rule that uses the state of a virtual switch to control one of these problem dimmers. The rule always runs an on or off command and immediately follows it with a set level 0 or 99 command. It's very reliable this way (100 out of 100 times). It's only 6 dimmers, so I guess I can use this hack. I'd appreciate you letting me know if you have seen this before or have anymore info. Thanks.

Not in any way saying this to diminish your issues with them, but simply to answer your question .. I have about 25 GE 14294 switches in my home and never experience any issues with them. If I were to throw out completely wild guesses of something to look at ...

Have you done a Z-Wave repair? I'm with you that it isn't likely a range or interference issue since the LED does show the state you expect. But it won't hurt.

Is there any possibility at all that you have line and load reversed on the problematic switches? I can sort of see a theory where the switch might still work but in a bizarre way.

But before doing anything, I suggest calling Jasco. You are correct GE and Honeywell are both made by Jasco. I think they'd have some good ideas. I don't think this is Hubitat related at all since the switch is indicating by LED that it knows whether the load should be on or off; it just isn't switching it.

If the led light on the device is changing, but the actual light is not turning on and off then you have a defective switch or an incompatibility.

There is nothing on the zwave network or the hub that could make the device do that. It would have to be defective, or there is some incompatibility with the load/bulbs and that switch.

Try putting a regular incandescent bulb on the switch and see if the behavior is the same. If it's a bulb/load issue it will probably work fine. If not, could be a bad switch.

Also what driver are you using? The Built-in driver? Or a user driver?

I have many of the same dimmers and do have issues from time to time.

Here are some things to check:

  • Do the dimmers work as intended when controlling them from the physical wall dimmer? Just want to rule out any wiring issues.
  • What device driver are you using?
  • What are the results from HE device, when you set the level to 99 then back to 0? Is it having the same issues when turning the dimmer On and Off?

Yes, I've try doing a Z-wave repair multiple times with no change. I'll contact Jasco to see if they have any ideas.

I thought about them being defective, but 6 out of 6 is a pretty bad failure rate. It could be the bulbs. The six dimmers control the following bulbs:

  • Three 60W (9.5W) Cree LED A19 bulbs
  • Six 65W (9W) Panasonic LED BR30 bulbs
  • Four 65W (9W) Panasonic LED BR30 bulbs
  • One 100W (12W) Great Eagle LED BR30 bulb
  • One 100W (12W) Great Eagle LED BR30 bulb
  • One 100W (12W) Great Eagle LED BR30 bulb

So I have several different bulb combinations, but all the GE/Honeywell dimmers have issues. I'll try some incandescent bulbs (if I can find some.)

I'm using your "GE-Jasco Z-Wave Plus Dimmer" v1.8.0, but I've also tried v2.3.0 and the built-in Generic Z-wave dimmer driver. They don't make a difference.

Yes the dimmers always work correctly when using the physical paddle switches. Also, if the dimmer "fails" after a command, pressing the paddle switch will always correctly turn off or on the light bulb.

Yes it has the same issue setting the level from 99 to 0.

Like I said in the first post, If I send a command to turn off the switch and then immediately send a level set 0, it always seems to work. It's really weird. I'm either unlucky (6 out of 6 bad dimmers) or crazy... probably both. :crazy_face:

I'll post here if I get a response from Jasco.

Hmm... Do you know what firmware the switches are on? Jasco is notorious for changing switch/dimmer behavior in different firmware revisions (QUITE annoying).

For instance v2.1-2.3 of my driver implemented a number of workarounds for a new firmware version. It obviously didn't help you, though.

Maybe they changed something, and the drivers need to be updated to accommodate.

Also, are they the new shallower/quick fit models (ZW3010), or the older deeper models (ZW3005)? Annoyingly, they both are model 14294, so can't tell from just the 14xxx model # alone.

The ZW3010 definitely need a different driver. Although I would have thought that simple ON/OFF would have worked regardless of the driver used. If it is the new shallow models, try my GE Enbrighten driver (posted on here and github).

How do I check to see which firmware the dimmer is running?

I pulled out the easiest one it was to get out. It's the ZW3005 model. I also confirmed that the line, load, and neutral wires were correct.



I'm guess the 1843 is a date code.

@JasonJoel
@glenn
@HAL9000

What do any of you have the configuration parameters "Z-Wave Dimming Steps" (Parameter 7) set to on your dimmers?

In addition to trying a dimmer with only incandescent bulbs (no difference), I removed all my GE/Honeywell dimmers from the z-wave mesh, did a Z-wave repair, re-included all the GE/Honeywell dimmers, and then did another Z-wave repair just to see if anything would be different. After this all the dimmers seemed to be reliable.

Excluding and then re-including the dimmers apparently reset their parameters back to default, or 1 step for Z-wave dimming steps and 3 (30ms) for Z-wave dimming duration (parameter 8). These default settings make the dimmer have a 3 second dim up/down rate. I previously had all my dimmers set with Parameter 7 (z-wave steps) as 99 and Parameter 8 (z-wave step duration) as 1 so I would have the shortest possible ramp up/down rate.

It seems to me that these Jasco dimmers have a firmware bug associated with Parameter 7 (z-wave steps.) I've done some more testing. I see this behavior will all my Jasco dimmers:

  • If Z-wave dim steps (param 7) + 2 > dim level,
    then on/off commands will be UNRELIABLE. Otherwise on/off commands will be RELIABLE.
  • For example if you have dim steps set as 99, as I did, then sending an on/off with any dim level will be unreliable because => 99 + 2 = 101 and the max dim level that can be set is 99.
  • If however you have dim steps set to 50, then on/off will be reliable as long as the dim level is (50steps+2) set to 52 or above.
  • If you've never adjusted the z-wave dim steps, then the default is 1. Sending on/off will be reliable for every dim level except 1 or 2 (1step + 2 = 3), but reliable for everything else (assuming your LED bulbs will turn on that low).

Can someone with a GE/Honeywell dimmer try this out to see if I'm crazy or not? I never set my dimmers below 10, so setting param 7 to a value of 8 works all the time and the ramp up/down rate is short enough at 125ms.

Mine are all at default - Steps=1 and Duration=3.

I'm just using the Generic Z-Wave Smart Dimmer driver. Not even sure how I'd check those parameters. Definitely have never set anything different from default.

@HAL9000 There is a Basic Zwave tool in the Hubitat Public github repository. You replace the driver for the device you want to make changes to with the Basic tool, make the parameter changes and then switch back to the original driver.

Hi @bdh.public,

I was able to replicate the issue by doing what you said, setting dim step = 99 (parameter 7) and dim rate = 1 (parameter 8). Once I did that and clicked Off, HE indicated the dimmer was off but in fact the dimmer was still on. Once I set the dim rate back to 3 (default) while leaving the dim step @ 99, the On/Off worked again. The test was done using a GE/Jasco ZW3005 Z-Wave Plus Dimmer.

I also tried the same test on a GE/Jasco ZW3005 Z-Wave (non-plus) Dimmer but in this case the On/Off continued to work.

So I guess you're not crazy, well you might still be crazy but not in this case :stuck_out_tongue_winking_eye:

:man_shrugging: Wouldn't be the first time there was a bug in Jasco's firmware... Especially on parameters that the majority of customers don't use.