Control and Query your Tesla vehicles (via

Any guidance on what I should check on Tessie? I've been a Tessie lifetime subscriber since they launched and it has always just worked. It refers to my cars as "Model 3" and "Model X".


The Tesla Connect app can obviously see the vehicles from Tessie since they appear in the logs. It just doesn't present them in the drop-down for me to select. Wouldn't that suggest the problem is on the Tesla Connect side?

i need the entire log with all 5 vehicles showing found not just a snippet.. if the car has no vin. .that is an issue it will be ignored as vin is required for all tessie commands.

1 Like

i will also need the found x number of vehicles and that output with full debugging on.. my guess is if there is no vehicle id and vin it is getting skipped which is correct.. i need both

1 Like

Yeah, I just started to look into the app code and referenced my log details. It is logging "Found 5 vehicles" and I never encountered the string "Found an invalid vehicle without a vehicle id... skipping!". My vehicles have vehicle id and vin. I'll have more time to spend later tonight to look at the code, but for now, I'll send you a PM with the full logs. Hang on. Thanks in advance for helping me.

full logs should be enough for me to figure out what is going on and fix it.. if it is finding five vehicles and they have vins and ids we should be good and i should be able to get it working.

1 Like

put version 1.99 up there.. moved a line of code around and added more error cases..
it would as was written accept a car without a vin which wouldnt have work but did NOT have the line in the correct place to work with a car with a null vehicle name. It only accepted a blank name. not sure why it is null that should not be allowed according to tessie.

but try 1.99 should work around it and if null assign the name tesla ##### # (id number)

if you want a meaningfull name in the logs and driver you will need to change the Device label in the driver (do not change the device name or it will keep readding the car next time you run it)

as an alternative you could try naming the car in tessie that should have also fixed it.

but version 1.99 is on the github.

1 Like

Thank you! I'll give this a try later tonight!

the other issue which is really more serious is that those loaners that appear in you account with a valid id and vin, means you could probably control them through the app and /or tessie.. have you tried for instance unlocking a door on one of them in tessie..

That is a major security hole.. the vins should be removed from your account as soon as you return the loaner.. i know when i had a loaner it was) In addition, if more than one person still have them in their account like you (that in essence means you still have a key for them) more than one person could control them at once.

they are greyed out it looks like in tessie so maybe there is some other setting in their that doesnt let you control them... i hope so.

It works! I can add my vehicles. And thanks for the tip about changing the Device Label instead of Device Name. In the app code, would it work to locally replace <null> in vehicle_name with the value from car_type?

No, I cannot control or view the current status of the loaners. They are essentially just historical data from the period they were in my possession/account, which is great because I don't have holes in my data/statistics when my vehicles were in service. They don't appear in my Tesla app or account anywhere... just Tessie.


you may want to let tessie know.. from your description once a car appears in the tessie account it may not ever remove it.. Probably the same for cars you sell? or maybe the tesla app and others only show cars tagged as owner.

I suspect that the vehicles need to stay there to keep the historical data…? And the VIN of any car can just be found by walking to it and taking a pic of the windshield… so likely not an issue…

Yeah... It really feels like an intended feature. There's no way I'm the only Tessie subscriber to have ever gotten a loaner. And I like the way it works now. I don't want that data to be lost. Maybe hiding the vehicles behind a toggle instead of just greyed out would be a future improvement to keep the list of vehicles concise.


Getting more and more disappointed with Tesla, when they are requiring fee for access their API. Aren't we paying already too much for the car? I looked for solution where I can get in the internet a "button" where I can remotely open my car, if I accidentally locked myself out of it. Happened to me twice on a parking lot in the park. Not sure how to justify $150 a year with tessie for a simple possibility to open my car.

how do you get 150 it is 5 per month, if you sign up use my referral link to try for a month

sorry guess price went up since i signed up.. that is a steep raise!!!

well, yeah, I just went to their website to check on it :slight_smile: let me find your link (didn't read whole thread) and try it. But still for 1Megabyte transferred data in a month still expensive.

on the other side $400 lifetime ... sounds not that evil much. But I doubt I will have my car more than for the next 3 years (probably gonna break something). Currently I do have 55k on my T3

It will still be usable with your next car if you get another Tesla. Otherwise, yea, it may no longer be of use then.

1 Like

Get the Tesla Smart Remote app. It’s a one time $5. Also has an Apple watch app which makes it a Bluetooth key just like the phone.

It’s a great backup and it’s “local”, doesn’t need the API. It has also worked great for my wife when she doesn’t want to take her phone when she leaves the house to go the park for a run.

Yes, I have Tessie too for the automation. For your use, the Tesla Smart Remote would be perfect.

Edit: sorry, reread your message and missed the need to unlock the car through the internet and not when you’re physically next to the car with a dead phone.

1 Like

I left twice my phone in frunk and car locked. Also tried watches but dont like them. So was trying to find something where I can ask stranger to use their phone to unlock my car

I'm suddenly seeing requests and commands failing with 429 'too many requests' errors, despite there not being that many requests. Doing the same actions directly in the Tessie interface (eg starting charging) seem to work fine so is this the Tessie API reporting an error or passing through an error from the Tesla API for some reason? I thought the point of the paid Tessie API was that you didn't have to worry about numbers of requests (within reason)?