Contact sensing problem since

I have a Fortrezz MiMo2+ that I use for controlling my garage. As soon as Hubitat update hit last week, the contact reads stopped working. At the time of the update, one door was open, and one door was closed ... from the Hubitats perspective, the doors are still in this state and there doesn't seem to be any obvious solution. I've power cycled the MiMo2+ many times, and done reboots of the HE but the situation persists, I even left the MiMo2+ unplugged for several days to no avail.

I upgraded to today, but that hasn't rectified the issue either.

I would have tried rolling the HE back to a prior firmware, but couldn't figure out how. The only obvious thing I haven't tried is removing and re-adding the module as I really hoped to avoid it (this could take a couple hours of effort due to the extent that this thing is integrated in rule machine rules, and I'm not even confident that it will help).

Although it's possible that the module did actually die at the same time as the update, I much more believe that the problem is related to the update itself. Has anyone else run into anything similar?, and if so, how did you fix it?


1 Like

To roll back, use the Hubitat Diagnostic Menu (http://your_he_ip:8081/), and then select the option "Restore Previous Version".


Are you using the built-in driver or a community driver? There were some recent internal Z-wave updates and one of my devices needed a little tweak. Perhaps @bcopeland could comment.

You are not alone. Contact sensors state not updating

1 Like

Same happened to me. Both my MIMO Lite and my MIMO2+ have stopped communicating with the hub as of that same update.


I can confirm that rolling the hub back to fixes the issue.

1 Like

Well .. misery loves company; but personally I'd rather have a solution. lol
At least this seems to confirm that it was the 115 update that broke things, I was still only able to point to that based on timing. When I saw 116 available today, so soon after 115, I jumped on it hoping it might have had a course correction. Sadly, that wasn't the case.

I am using the built in driver ... it's been rock solid since it was released.

I may try this just to see if everything returns to normal ... I searched all over but couldn't seem to find anything. Thanks!


I can also confirm that this fixed it.

Since @mike.maxwell was working on something similar to this with @greg4 previously, perhaps he can provide some insight as to what changed in, and whether this is a permanent condition going forward (i.e., will we need to replace the MiMo2+ modules if we want to install future updates)

As I said earlier, there were some internal Z-wave updates that required updates to a lot of drivers. Some things may have been missed or didn't work as expected. This is likely a small change and I am sure once @mike.maxwell or @bcopeland see this issue it will be fixed.

1 Like

found the issue with the mimo2, will need to include a lite to see what the issue is with that.

1 Like

well, in that case, I'll toss out the other odd behavior I noticed with the module while running .115.

The relays were still 'sort of' controllable, but they only seemed to be good for a single action and then I needed to power cycle the module. Mine are configured as momentary .. I could activate them, but they wouldn't release, and I couldn't deactivate them without pulling the plug. That was main reason I thought the device could have actually died. It was just weird.

Never mind ... seems you fixed it faster than I could even type the extra 'possibly helpful' information. :slight_smile:


The mimo lite appears to function correctly with the built in driver, which driver are you using?

Same problem corrected by rolling back driver to *.132. I will wait for Hubitat to work out the bugs before updating the hub again.

I have the same problem with my Fortrezz MiMo2+ .
I use it to control my garage.
same as you as Hubitat update hit last week, the contact reads stopped working.
Since my door were closed, at hubitat the show closed 24/7 no matter what happends in real life, they will show closed at the hubitat app and ip panell.
Also my relay are inres´posive, they will never update at hubitat.

So if sombody open my garage or street door my siren alarm, dose not sound, have no way to know it the door or the gate wa opened. And it is imposible to use the relays since you have no idea if the gate is opene or close, and if used theres is no way to know if it worked.

Before reading this topyc y wasted 6 hours, trying z-wave repare, moving my hubitat to the garage and have a 60ft cable for the ethernet conection, etc...
Nothing worked.
Done reboots of the HE, just like you did, but the situation persists.

The fix for this will be in platform version 2.2.2

1 Like

:+1: :grinning: :+1:

1 Like

@mike.maxwell, I'm using the builtin driver for the MimoLite. It works now that I rolled it back to but did not work just like the MIMO2+ on Did you sort this out already for the Lite?
Is there some other info I can provide you to help?

while running platform 2.2.0, can you enable debug logging in the driver, open live logging, open/close the contacts then past a screen shot of the logs here that would be great, thanks.

I just updated to and it now works. Whatever you did fixed it. If you still need me to go back to where it didn't work or where it did and capture the logs I am happy to do so.