Constantly losing connection to my hub

The HUB is constantly dropping from the network - it has a static IP address. A power cycle will solve the problem - however, this is obviously not a solution. Not sure what else to try to maintain the connection. Any suggestions would be very helpful. Thanks.

Could you provide more details of your setup? Including:

  1. Hubitat model
  2. Connection method - WiFi or Ethernet
  3. Connected directly to router or via a switch?
  4. Router/Switch brand and model

And have you tried the following yet:

  1. Changing the Ethernet port used on the router or switch (off Ethernet connected)
  2. Changing cables?

Changing power supply? Is it on a UPS?

And just how do you power cycle? By doing a clean shutdown to red light from Settings > Shutdown, then pulling power at the wall (not at the micro USB, which is fragile), then apply power after 30 seconds?

Is there any light on the hub when it is not accessible?

1 Like

What if you just unplug/plug-in the network cable, does that bring it back rather than rebooting the entire hub?

1 Like

When it becomes unreachable, can you go to http://ipaddress:8081 ? (not https)

1 Like

I haven't tried 8081 when the hub is down.

Try that, it may lead to a solution. If it does and it's available , let @gopher.ny know so he can check it while it's in that state. Though if you can, it seems it will indicate a database corruption.

I have the same issue, for me it started with the upgrade to 2.2.6 but also is still there when I rolled back to 2.2.5. It would work for a while and then stop responding to ping. no response on 80 or 8081

here is a chart of the packet loss, whenever the hub is down it goes to 100% loss, then I reboot it and it comes back up, sometimes for a few minutes, other times for a few hours:

What's interesting is that z-wave automations keep running just fine, but HTTP ones fail (obviously), so things like MQTT light control or Alexa and Homebridge no longer work, but if I try to do a scene control from my ZWave switch into rule machine, that works fine.

My Setup:

  1. Hubitat model - C7
  2. Connection method - Ethernet
  3. Connected via a switch which is a known good switch, and a known good cable, the device worked fine and was not physically touched for the last month but started having issues as of the 2.2.6 update.
  4. Router/Switch brand and model - Ubiquiti EdgeRouter 10X / Dell PowerConnect Switch
1 Like

@gopher.ny, will look at the hub light next time it locks up.

So the network goes out and reconnects upon reboot while everything keeps running.
The networking stack reconnects on its own if, say, cable is unplugged and then plugged back in, even hours later. So this is some situation when reconnect doesn't happen. Need to dig into that.

If z-wave or zigbee automations are running, your light is going to be green.

@gopher.ny, I have not tried just pulling the cable ... I've been doing a power reset, either an immediate reboot or a remove power, wait 5 min and add power.

I have a network addressable power outlet that I've been using for the reboot.

Should I try pulling a network cable and plugging it back in?

It's worth a shot. I'd say the likelyhood of it reconnecting is low, but it may help narrow the issue (and come up with an eventual solution).

BTW, I've put together a "driver" to gracefully reboot the hub using a Kasa plug some time ago. Not that it helps if network connection is out :slight_smile:

Yeah, that's the problem isn't it? I can go and remotely reboot it, but I still need to go see that it's down and do it through the PDU interface.

But also, I worry that every time I do a hard reboot like that, that it will corrupt something in the device.

The chance of it happening at any given time is slim, but yeah, probabilities stack up over time.

Curious. I know that your HE has a static ip, do any of your other devices? Also are you referencing the netbios names anywhere in your setup?

So the way I have it set up is slightly unique:
All devices get their IP from a DHCP server with many server like devices (e.g. NAS, printer, switch) have IP statically reserved so they always get the same IP
Then my internal DNS has domain names defined to pair friendly names to the IP addresses.

not really using the netbios name

Ok, reservations are great. Try this. Set up everything involved not to use names but to use the actual IP instead, bypassing the DNS. It may solve your problem. I get the feeling as your stuff is coming up it's not recognizing canonical names right off the bat. (Not saying that actually what it is but seems a symptom). By using the ip directly for everything in your iotsphere that could be eliminated as a potential failure point.

For my ping test Iā€™m using the ip, and that starts failing as soon at it locks up. Basically if I have a continuous ping test going, I would see it start getting timeouts once it freezes and back to normal after a restart.

Are you running a vlan?

Download the Hubitat app