Connect to Hub is not available in the mobile app when connected with VPN

When I connect to my LAN via my VPN server Connect to Hub is not available in the mobile app. Full control of the hub is available through the VPN in the mobile browser. What I get is the Remote Admin subscription page. I do not understand why this is
disabled when I'm connected to my local network.

I see the same thing. Not sure why that happens, but if you need to connect you can still go into the Registered Hubs section and connect to your hub there.

Not looking for a workaround. If I'm connected to my local lan via vpn the mobile app should be fully functional.

Again, I can't comment for sure... But my suspicion may be something networking related, which may not be able to reach your device when on the VPN, compared to how traffic is routed on Wi-Fi.... but definitely not my area. Hopefully I'm wrong and there is an easy fix, but I've noticed it being this way for some time myself, but I don't use my VPN much.

At first I thought my vpn wasn't working. All other aspects of the Hubitat mobile app work. It is only the "Connect to Hub" functionality. This appears to be a design choice. Access to the hubs ip and all other local network devices are fully available to me.

The other aspect that makes me think it is networking related is that the active connection to the hub in the Settings, which is the one you connect to from that link, and that is used to receive notifications, is based on a selection of a mobile device configured when you first connect with the app. That mobile device likely has an IP address associated with it in some form, and I'm guessing an active connection in the background, or at least that connection tied to your router's public IP and a port. Once you change IP addresses and the network setup underneath, it would make sense to me that it becomes harder to automatically adjust to in the App. Again, my suspicion would be the links on the Registered Hubs page are simply links like any other you open in a browser, not having the concept of an active session / connection associated with them.

All this could be completely unrelated and there's an easy solution... hopefully... just me spit-balling ideas.... I should probably leave it for the staff to respond....

I have no difficulty connecting to my hub with the mobile app while my phone is remotely connected to my wireguard VPN server at home.

Perhaps sharing more details re: your VPN setup could help clarify why you’re unable to.


Typically, when you connect to your own home via VPN, the IP address that is assigned to your Phone will NOT be in the same VLAN as the rest of your home network. My guess is that the Hubitat Mobile app sees that the Phone and Hub are on different VLANS, and thus assumes that you are not really at home on the same LAN. Therefore, it pops up the Remote Admin option.

UPDATE: Like @marktheknife, after running a quick test using my iPhone connected only to LTE network (no wifi), and the VPN'd to my home via Wireguard, I too can easily access my Hubitat Hub without any issues.


Using the connect to hub option in the tools menu? And do you have remote admin?



Strange.... But in a good way.... Means there must be a way to get it working ...

Presumably with the right VPN configuration. I haven’t done anything on the Hubitat side to get it working for me.

1 Like

Not sure why, if VPN access is available, one wouldn't just use the hub's IP address to access it...that's what I do over VPN (also WireGuard) when I'm away from home, just as I do when I'm at home.

A little Googling suggests that I can reconfigure my openvpn server to provide a 192.168 address. Right now it gives a 10.. I only noticed it because I was adding a user to my vpn server and was testing it on the phone Android Openvpn app. Reality is that I never use the Hubitat app to configure anything. I always use a browser either in my Chromebook or desktop. The working, in all other respects, openvpn server will not be reinvented.

Not sure if it has something to do with OpenVPN vs. Wireguard.

When connected remotely through wireguard, I’m not on the same exact subnet as when I’m local. 192.168.1.x vs. 192.168.2.x (just as @ogiewon mentioned).

No issues reaching the hub despite that.

1 Like

Same. my WG setup uses, but I have full access to my home networks when connected via WG.

Same here. My Wireguard VPN server is configured to assign IP addresses in the 192.168.222.x/24 range. My hub is in the 192.168.1.x/24 LAN.

1 Like

I have full access via 192.168.1. any specific ip. The only limitation I've encountered is "Connect to Hub" in the Hubitat mobile app. All other app functions are available. I have full access and control of the hub via mobile Chrome to the Hubitat local