Confusion With New Remote App not working, and with Dashboard Showing 0 Devices, and Local vs Cloud Dashboard

Not really a new user, just get a setup and then don't access Hubitat (C-8) for multiple months, then come back and am easily confused by what's going on. I have a couple questions, but will start with providing feedback for the Hubitat folks illustrating my novice frustration and confusion, as it might be insightful.

In this case, I pulled up the mobile app (iOS) to get on Hubitat, and a dialog popped up saying the app is going to be retired, and i should consider getting the new app. So I downloaded the new one from the App Store, and opened it. Then I was met with "This is a new device" (my iPhone), so I gave it a name and proceeded. Unfortunately, selecting Connect To Hub caused the new app to hang up. I tried a few things, it was saying there was no internet access, when everything else on my phone was successfully accessing the internet, but the app continued being generally unresponsive. Eventually it provided a display in the tiniest font imaginable, illegible until I blew it up, saying "This hub is not authorized for remote access". That of course worried me. I started surfing the Hubitat Community, eventually stumbled upon various recent topics saying there are known problems with the new app, as of a few days ago.

OK - one suggestion would be to possibly amend the current dialog that's telling everyone to stop using the old App, to maybe point out that the new one is not yet working?

So I reverted to the old App, and it said the firmware was in need of update, something i've done multiple times successfully. I initiated the update, and it got stuck on a screen claiming it was doing a rebuild, but it never got past 35%. On that screen it recommended that if I was stuck on this screen, I should investigate troubleshooting, try diagnostics, and possibly consider a soft reset. Back to surfing the Hubitat Community, never successfully got to the Diagnostics screen, but eventually determined that I could indeed access the old App OK. With some trepidation, I moved on.

Another source of confusion though, after hitting Select Hub and picking my Hub, I was greeted with 'We found existing Mobile App Devices on your Hub, please select which one you want to use or create a new device". After scratching my head for a while, I realized that I apparently had chosen a slightly different Mobile App Device name when I started the New App, such that now I had 2 choices for the same device. I started to realize what is likely a valuable lesson - on most applications, how you run it on the computer is pretty much identical to how you run it on the mobile device/iPhone. But on the computer, I access the hub directly, via an IP address, but not at all the same when I use the iPhone App. Maybe everybody else inherently understands this potentially significant difference, but it's taken me a couple years to absorb this.

OK, finally to my question(s). Now, when I get to where I'm picking my Dashboard (on the Old Mobile App), my Dashboard is listed, but says "0 Devices", which caught my attention. At the top of the display, it says "Dashboards (cloud)", but also shows a House icon. When I go ahead and select my dashboard, success, all my devices are populated on my displayed Dashboard, which works correctly. However, if instead I click the House icon, it changes to a Cloud icon, and the top now reads "Dashboards (local)". Now clicking my dashboard does nothing.

It's certainly possible it always worked this way, but I'm concerned that I apparently have no "local" dashboard devices, only a "cloud" dashboard with devices. Is that the case? Is there something I should do to have it show the 23 devices I really have as the Local dashboard, and not show 0 devices?

Thanks for any insight anyone can provide, or any pointers to other related Community posts. I deeply appreciate any opportunity to learn more.


Did I put it in the wrong place? It's probably too long for most people to take the time to read. But zero replies in a week? Guess I"ll go back to searching other posts to find out how to solve my Hubitat problems.

Ignoring the app situation for a minute, I didn't see you mention if you tried to access your Dashboards on a desktop or laptop while on your local network.

I guess I am also assuming you actually have some dashboards built? Are they the classic dashboards, or the newer EZ dash?

For this issue, this will probably be fine.

Thanks for the reply. The app seems to have worked itself out by waiting, the new (updated) one is now working. When I select my hub, I get to the standard display where I can select Rooms, Devices, Dashboards, etc. when I select Dashboards, it shows my Dashboard name, and under the name, it says “No drvices”. Now when I select the Dashboard, it comes up as expected, with all my devices. Just sort of disconcerting when the previous display says No devices. But other than that, everything appears to be back to working normally.

And I’m sure it’s the legacy Dashboard, I haven’t got around to learning about the new Dashboard yet .

Thanks again!!