Commands lag

I've been having an issue for quite some time now with lagging. I give a command either via Alexa or the Hubitat app, a scene, or through the browser and sometimes it takes up to 30 seconds for some of the lights to change to the desired state. When I first installed Hubitat, years ago now, everything happened almost instantaneously. I didn't see any of theses issues until I installed the innovelli equipment, specifically I'm suspect of the two Inovelli Bulbs (Multi-Color LZW42) that I have. Nice bulbs but they seem to cause issues. I had some issues with these bulbs when I first got them and had to install different drivers to get them to work. Then, after a while I had to install, yet again, different drivers. So, I'm guessing it's something to do with those bulbs, but I'm not positive on that.

Any ideas on where I should start to trouble shoot this issue?
Thanks

So it is the scene you are triggering directly from the HE app or Alexa, there's no rule or something else in between? Then I would start by looking at the setup of the scene and turning on any logging you can for the scene and the devices involved in the setup of the scene.

What hub model do you have?

Rev C-5
version 2.3.1.142

Yes, either a scene from the HE app or browser or a Alexa command. I don't often trigger on light or directly from the HE app or browser. It's usually Alexa or the app on my phone. For instance, I have a "nighttime" scene that triggers all of my indoor lights to turn off except for my bedroom lamps (the innovelli bulbs mentioned) and turns my outdoor lights up to a specific %. That nighttime scene triggered through the app sometimes takes 30 seconds to complete for all of the lights. When I turn the two lamps off via a button on the dashboard set to control those two lights in a group... they also can take anywhere from 10 - 30 seconds to turn off. Logging is turned on on most of my scenes if not all of them, I believe as I had this issue in the past.

Have you noticed the lag affecting only Z-Wave devices? Performing a Z-Wave repair may reduce the latency. It sounds like one or more repeating devices are not working as well as they should. It could happen when you introduce new devices in your mesh. The Inovelli bulbs are known to cause issues on C7 hubs, but not sure about C5.

I might try that. I do have mostly Z-Wave devices.

Watch the Logs while the repair is running. Having failed devices would be indicative of a troubled mesh that requires further attention.

I don't have any of these, but the lag isn't normal.

There have been firmware updates to these bulbs that might help. Do you know what firmware you are on? https://support.inovelli.com/portal/en/kb/articles/firmware-change-log-lzw42-rgbw-bulb

You also could turn on all the logging on the device, and logging on the app controlling the device (the rule, or motion lighting or whatever) and watch the logs to see where the delay occurs. If you screenshot that log, someone might be able to pick something out.

While you are in logs, are there any errors in that section?

Lastly, is there any app or device in the App Stats or Device Stats tab of logs that has heavier usage than the other apps/devices? If you post those, again someone might be able to see if there is some device or app that is slowing the hub.

2 Likes

@BrandonT an you post a copy of your z-wave details page?

He has a C-5, so it’s probably not going to be super helpful.

2 Likes

I ran the z-wave repair. No failed devices in the logs.

1 Like

I am running

  • protocolVersion: 4.38
  • hardwareVersion: 255
  • firmwareVersion: 2.28

It looks like I'm one version behind on the published firmware. I may try to update the firmware on those when I get a chance.

If he has any devices with no in/out clusters that could be a problem....

That's great news! Unfortunately, you may be correct that the bulbs may be causing problems. I suggest to temporarily exclude them to see if that reduces the latency (be sure to run another repair after you exclude the bulbs).

1 Like

Depending upon the firmware version you definitely want to update if possible. Also make sure you are never cutting power to the bulbs according to the instructions.

2 Likes

I don’t have a C-7, but none of my Z-wave devices have out clusters. Since it seems clusters are a Zigbee thing and are really just command classes for Z-wave; are there out clusters with z-wave? I have a Zen77 that I powered up just long enough to update the firmware, but didn’t exclude it. That was a couple months ago and it doesn’t look any different from the others. BTW, I plan to install it soon and know that having it powered off could cause problems.

C5 has in out clusters as does the c7. On the c7 they are at the bottom of the device page. In the c5 no in/out on the z-wave denotes a ghost

1 Like

Tell me you don't have Zooz ZEN25 devices ?

1 Like

Or 40's

Download the Hubitat app