Coming over from SmartThings


#43

Hehe.

Good point on open windows during rain. Sadly (a) I live in the UK, so of COURSE it's going to rain... and (b) it's an 18th century farmhouse... so most of the windows don't fit together that snugly :wink:

Oh... and incidentally... there's nothing like 3 foot thick walls to block RF signals. HA meshes are holding up surprisingly OK... but we're currently at 9 Wifi Access Points to cover the place :wink:

-- Jules


#44

I would love to see a pic of your house.


#45

Just a quick update... After rough porting my ThingShield/Garage Door Control code over to HE, there remain about 16 critical devices on SmartThings that still need to make the journey.

I've now moved 406 devices to Hubitat, although 5 are device groups using the groups app.

One issue I'm still woprking though.. I've been experiencing weird issues with Zigbee pocket sockets occassionally going unresponseive. If I press on/off a couple times, or configure, they come back to life. I've ported over my old Iris Smart Plug code with a few tweaks and moved all 52 devices over to it today. It has health monitoring and I added some automatic recovery options. So far, no plugs have gone unresponsive since.


#46

It would be excellent if the driver was the issue, We can all learn from "better and better" drivers. :smiley:

My first reaction was of course, signal-to-noise ratio. I'm sure you know, but for others reading this next year, 2.4ghz (Zigbee) attenuates faster than lower frequencies. And we all have a nice 2.4ghz "interference generator" in our homes, called WiFi. Thus the signal you want the pocket socket to receive is buried in a lot of noise. The position of a door, can affect the bounce.

Thus, your devices could be dropping off because at certain times of the day, this door is half closed, while when you go around fixing it, the door's open. Obviously I'm talking about extreme cases and your experience with 400+ devices is going to be a lot more relevant in your house. :slight_smile:


#47

Wonder how this is affected by Mesh systems like Google Wifi or Orbi


#48

The driver isn’t the issue however I have mine set up to configure the plugs to report on/off status every 10 minutes. This serves as a way to report that the plug is still alive. I have the driver monitoring for that heartbeat and trying to refresh the plug of it falls offline.

There’s definitely something up with the mesh. But Z-Wave also affected too. Both meshes were stable in SmartThings, it was the cloud that was killing me.

I need to figure this out.


#49

Did you repair the z wave and turned off the zigbee for 15 minutes? You have a ton of devices so will take time those repairs.


#50

Another datapoint I neglected to mention is that when the SmartPlugs fail to respond I also do no see any corresponding entries in the ZIgbee real-time log. I would think that if there is no log entry for an on/off command in the Zigbee log, I would conclude that the command is being lost somewhere in the hub or the Zigbee stack prior to transmission.

@mike.maxwell should all Zigbee messages (transmitted and received) appear in the Zigbee log? If that’s the case, I am seeing multiple occurrences of sending an ON command but no entries in the Zigbee log.


#51

Zigbee log?, not following...
Are you meaning no entries in the live logs and the device logs?


#52

When I execute a device command for a pocket socket, occasionally I’ll have to send the on command 3-5 times before the plug responds. In the zigbee logs only the last command is ever displayed.


#53

Right, the command is not reaching the device.
So something's not up to snuff mesh wise, you don't have any zigbee bulbs paired directly do you?, if so try unscrewing those in vicinity of the problematic outlet and see if that changes anything.


#54

With the exception of my detached garage, I have no smart bulbs outside of Hue. HE is using Zigbee channel 21, Hue is on 25. I have 4 Osram bulbs on my garage 100feetfrom the house, so I don’t think any traffic is routing through them.

I have 2.4Ghz WiFi running on channels 1 & 3, with my tenant using channel 5. There could be so,e sideband lobe interference from their WiFi but that shouldn’t cause the issues I’m seeing, especially sine SmartThings is on channel 15. In theory that should be getting clobbered by the WiFi on channel 5, but it’s working great.

This feels like a routing issue. I have got 2 plugs Side-by-Side on a plug strip. One plug works every time, while the plug next to it often requires a couple attempts. Plugs in the basement 3 stories down are lightning quick while a plug in the same room as the hub is not.

I’ve power cycled all of the plugs in the past day. I took the hub down for 30 minutes yesterday to force the Zigbee mesh to heal, but today’s it’s worse than before.

The pocket sockets (Iris & ST) are the only Zigbee repeaters in the house. In the detached garage I have a ThingShield and 4 Osram bulbs for repeaters.

I’m at a loss as to what’s going on.


#55

These are bad repeaters...
Even though they are far away, unscrew the lot of them, then pull each socket, this will force them to hunt for a new parent, then see how it goes.


#56

I’ll give that a shot tomorrow. I built the mesh outward from the hub so they really shouldn’t be participating in internal routing, but I need to track this down.

Thanks and Happy New Year!


#57

Happy New Year!

I’m afraid that didn’t have any effect. But I did learn one interesting pattern...

When the plugs are reset (physically, reset command) or become responsive through multiple attempts to control them, they remain responsive for a period of time. In otherwords, one they respond to a command they will respond to others for a while.

Another interesting observation. When the plugs are responsive and I reboot the hub, they go back to their previous non-responsive state.

As another control, In the room where the hub is located, I pulled power to every plug in the room for at least a minute. Then one by one I plugged them back in. They all stayed responsive for maybe 5-10 minutes them a couple went back into the state of needing to be sent several commands to actually respond.

The weird thing and that one pair of these plugs are next to each other on the same plug strip.

I’m truly at a loss for a solution.


#58

I wonder if the default poll control settings on these are lame, wouldn't be the first time that I've seen that.
Which specific models/PN's are the ones you're having issue with?


#59

All of them! But the majority are the 3320-L plugs from Lowes.

It just took 5 attempts to switch a plug in an adjacent room to the hub. I spaced each attempt at 5 second intervals. Of the 5 attempts, 2 appeared in the log along with a power report. Three were lost, but 2 indicate they were received at about the same time.

[Christmas Tree, Purple Room](http://192.168.7.249/hub/zigbeeLogs#zigbeeRx13331)2019-01-01 14:05:19.334 profileId:0x104, clusterId:0xb04, sourceEndpoint:1, destinationEndpoint:1 , groupId:0, lastHopLqi:255, lastHopRssi:-58

[Christmas Tree, Purple Room](http://192.168.7.249/hub/zigbeeLogs#zigbeeRx13331)2019-01-01 14:05:17.849 profileId:0x104, clusterId:0x6, sourceEndpoint:1, destinationEndpoint:1 , groupId:0, lastHopLqi:255, lastHopRssi:-56

[Christmas Tree, Purple Room](http://192.168.7.249/hub/zigbeeLogs#zigbeeRx13331)2019-01-01 14:05:17.848 profileId:0x104, clusterId:0x6, sourceEndpoint:1, destinationEndpoint:1 , groupId:0, lastHopLqi:255, lastHopRssi:-56

RSSI and LQI are good.

Edit: I just had a Iris plug go unresponsive that is 5 feet line-of-sight from the hub. Took 4 ON commands to get it to respond. Two are logged. RSSI is insanely high.

[Christmas Tree, Small in Office](http://192.168.7.249/hub/zigbeeLogs#zigbeeRx16545)2019-01-01 14:32:02.234 profileId:0x104, clusterId:0x6, sourceEndpoint:1, destinationEndpoint:1 , groupId:0, lastHopLqi:255, lastHopRssi:-19

[Christmas Tree, Small in Office](http://192.168.7.249/hub/zigbeeLogs#zigbeeRx16545)2019-01-01 14:32:00.833 profileId:0x104, clusterId:0x6, sourceEndpoint:1, destinationEndpoint:1 , groupId:0, lastHopLqi:255, lastHopRssi:-19

#60

I've been tinkering all afternoon...

To rule out inteference, I've changed Zigbee channel to 15, (was 21) which is the channel SmartThings used for years. Surprisingly, most of my devices changed channel within minutes...

Unsurprisingly, I'm still seeing the exact same behavior with plugs going unresponsive after a period of time, requiring multiple commands before they respond.

At this point, since the environment (WiFi channel & hardware, Zigbee channel) as well as devices (make, model, placement) is a constant from SmartThings just a couple weeks ago, and my SmartTHings issues were cloud-related, I must therefore conclude it's a mesh issue specific to the Hubitat environment/Zigbee stack.


#61

I'm not a Zigbee guy. I now have 5 devices, 4 motion sensors (iris v3 + one v2) and a Peanut Plug as repeater. Thus my experience is woefully inadequate to speak to what you raise, but...

Always a but.. huh?? :smiley:

There have been comments that the Antenna in the USB stick is not as good as... (pick your previous hub's name here.) And If so, that would mean additional repeaters are necessary for Hubitat vs others. However, Zigbee at 2.4ghz means the antenna can be tiny. The ZWave antenna of course is much larger.

The confusing data point is, for the Nortek USB stick, Zigbee and Zwave share a common antenna. Zigbee is on one side of the internal PCB and ZWave is on the other. The RF both hit F1 and then to the Antenna.

Being neither fish nor fowl then the rumors of "not as good as" could theoretically be true. Our EU and AU friends use two sticks instead of one and maybe they can give us a hint.


#62

I never got the answer if you tried to turn off the zigbee radio on the hub, wait 15 to 20 minutes to make all devices go to panic mode, then turn on the zigbee radio?

I had multiple problems with my hub[solved], but I never had any issues with zigbee and I have multiple iris plugs, the Google wifi is about 2ft away, 2nd hub is about 1.5ft from 1st. I use channel 20 in 1st hub, 25 in 2nd hub.

I think you should try Xbee, nice repeaters and you can map your mesh......