Color Bulb Tile is not working as expected - Not possible to change+save the color

I have a Shelly Color bulb using the system driver. I am able to change to any color in the dashboard tile, but when I close this screen using the "X" in the upper right corner it go's back to the color red, no matter what I do.

.

There is no issue when I change the color via the device page.
Note1: In this scenario the color on the the dasboard tile is not changing.
Note2: Changing the brightness is visible on the dasboard tile.

When I make a group with this specific device, I can change the group device color, no issues when I close the color bulb tile.

Any idea's why the color bulb tile is behaving like this and how to solve this issue?

I’ve tried this with one of my Lifx and one of my Hue bulbs, and it worked. Light changed color and stayed after X. Not sure why this isn’t working with the Shelly bulbs… Do you have any other bulbs to test with?

1 Like

unfortunately, no, but I am convinced it works for other bulbs as there are few complaints about this

What does "Current States" look like on the device detail page (not the Dashboard) for the problematic device? And does it update as expected when you change color or color temperature manually from this page (again, not the Dashboard)? If you're only having problems with this one device — and I suspect this is not a Dashboard-wide problem because other devices work fine for you and others — then something might be going on with the driver, which this could help figure out.

image

On, Off, set color, set level and color temperature are working fine from the device page

I am using the build in driver

@Sebastien still the same issue as your problem 3 years ago, Bulb color sticking to last RGB value on DashBoard - #8 by Sebastien

1 Like

It's a problem with the system driver, when I use a custom driver it works

1 Like

That's why I was wondering about "Current States." I agree that there is a problem with the driver and can see from the screenshot that it is missing the "hue" attribute, which is likely confusing the Dashboard. I think @mike.maxwell wrote this driver (or should know if not).

There could be something else going on here that is Dashboard-specific, but I don't see any evidence of that with the information available and know it works in (most? other drivers may also have problems) other cases.

2 Likes

Download the Hubitat app