Cloud connection stops working

I've been having a lot of trouble with cloud connectivity lately. I can't say exactly when it started, but roughly within a month. It could be related to firmware update as I usually always update when I notice a new version is available, but I hate to jump to that conclusion.

Things that don't work: Google Home integration stops working ("sorry I can't reach the Hubitat"), OwnTracks events are queued up on the mobile app because they can't reach OwnTracks, and my Hubitat dashboard is inaccessible using the cloud link ("Pretty print: No response from hub").

Things that DO work: Network test from Hubitat shows successful pings and traceroutes to, ping also works to random DNS-based addresses. Hubitat Package Manager can check for updates. My Hubitat portal indicates the hub is Active but the last check-in was 6 hours ago at this point.

Hub is a C7 running version I've had this hub in service for a couple of years without cloud issues. Wired ethernet (hasn't changed). DHCP configuration but using fixed address/reservation. I can reboot the hub which restores the cloud connection but it seems to happen again at some point within a few days.

My hub is currently in this state where the inbound cloud connections noted above don't work. What else can I check / what next steps should I take to find and resolve, rather than just rebooting to fix it temporarily?

What type of ISP connection do you have? What type of home networking router and other network hardware are you using? Have you changed anything on your home network recently? It is possible that your home networking hardware has had some firmware updates that are causing issues - just a hypothesis... :thinking:

A few easy things to try:

  1. Replace the Ethernet Patch Cable
  2. Connect the hub to a different port on your network router/switch
  3. In the hub's network settings, change the Network Speed from "AUTO" to "100Mbps Fixed" (or Vice Versa)
  4. Replace the C7 hub's USB cable
  5. Replace the C7 hub's USB power supply

Not sure if any of the above will help... Just throwing out some simple ideas.

Also, tagging @bobbyD from Hubitat who may be able to look at your hub in its current state to see what it looks like from the Hubitat Cloud side of things.


Could it be a firmware update on the router side? There were no changes on the hub side recently that may have affected the cloud connectivity.

Mind sharing more details about your network structure and hardware used?

1 Like

I can confirm from our side that your hub is not connected to the cloud. You can reboot and then let me know when the hub is back online.

1 Like

Thanks guys, good questions. I have rebooted the hub and it has restored its connection to the cloud. Would be great if you can take a look.

Other details that were asked: Internet is a consumer cable connection. The local switch & gateway are Cisco. Not ruling out possibility of an issue there however I can see the LAN connection is working with no errors and we know the hub can make outbound connections to the Internet.

I guess what I'd expect/wish for is that if the cloud connection is interrupted, the hub would/should re-establish after some retry interval but it appears to require intervention now.

FYI, I had a problem similar to this and it ended up being a DNS/IPv6 issue related to a firmware update on my older Unifi USG. Apparently, the latest Unifi network update to 8.1 broke IPv6 on the WAN side, and I run my own DNS server at home which had cached lots of IPv6 addresses. When my DNS server handed me an IPv6 address, the connection would not work because IPv6 was disabled by the update. Very frustrating. Probably not your same issue, but thought I'd share cause the timeline is similar.

I have also been experiencing issues with google home. The devices I have exposed from Hubitat become unavailable at random times every once in a while.

A reboot of the Hub solves this. I cannot detect any pattern. It's frequency is in weeks though, not hours or few days.

This morning my hub's cloud connection is down again, for (at least) a few hours now. Internet is up, the hub can make outbound connections (eg. HPM). Roughly 5 days since the last time. In the absence of implementing some sort of heartbeat / reconnect capability in the Hubitat itself (which would be ideal) I'm thinking I may be forced to implement my own sort of watchdog. I already use http://hubip/hub/restart as part of an automated backup process but two things would be useful here:

  • is there a similar URL/API I can call that forces a cloud connection reset, rather than having to reboot the hub
  • is there a page/API somewhere that reports the cloud connection status?

Typically when I see this happen it's something in the router. (aws hasn't been down). When this happens if you go to do you see your hub?

1 Like

This is really odd. I have anywhere from 3-4 Hubitat hubs up and running all of the time. I never experience any Hubitat Cloud server connectivity issues.

When you say that your local switch and gateway are Cisco... what exactly do you mean? Are these consumer grade devices? Or is this hardware repurposed enterprise grade equipment?

Configuring enterprise grade Cisco equipment is not trivial, and this I wonder if there is something going on with respect to that hardware. Just a hypothesis. :thinking: :man_shrugging:

I run a full Ubiquiti UniFi network stack currently, and used an Asus router and unmanaged switches previously. No issues with either configuration maintaining the connection to the Hubitat Cloud.

This is a great question for @gopher.ny from Hubitat. I have to believe that there is some sort of automatic reconnection logic, as my hubs always reconnect to the Hubitat cloud when my Spectrum ISP cable modem service goes down. I have never had to reboot the Hubitat hubs to reestablish this connection.

1 Like

Agreed that this is out of the ordinary - although I only use one hub at a time, I've been using Hubitat for years but this problem began a month or two ago for me.

I'm mostly interested in the last part - how can the hub better detect that its cloud connection is not working, and reset it? Today to reset it, rather than rebooting the hub I unplugged its LAN connection, waited 5 mins and then connected it again. I had previously tried the same thing without a wait (ie unplug, wait 5 seconds, re-plug) and that didn't seem to be enough. Even if the router is at fault (eg. purging the session state from its connection table - just a hypothetical), the hub should detect this and re-establish.

It is, but I have had a similar issue recently. In my case, there are two C7s on the same LAN connected to the same switch and only one of them had issues with inbound calls from Hubitat's cloud, so the network configuration / equipment are unlikely to be involved.

It shouldn't be necessary, but if you need to, you can do this with MakerAPI, RM and Notifications :

  • set up a MakerAPI instance to expose a virtual switch configured with auto-off set to 10 seconds.
  • set up an RM rule to periodically call the MakerAPI cloud (not local) endpoint to turn the switch on, say once per hour.
  • set up a Notification app instance to notify you if the switch turns off and remains off for over an hour (or whatever period you picked + some extra amount)

You could skip MakerAPI and just use a second RM rule with a cloud endpoint trigger and command the virtual switch on from the actions. You could also use an RM rule for the notification, of course.

1 Like

My C7 has been doing this as well. It has happened three or four times in the last couple months. It was very solid before that. It's kind of annoying.

I can login to the hub via app or web browser. I can ping devices on my network (to include the router). I can ping out to the internet (

As there is no way to reload the IP stack, I do a soft reboot of the C7 and it works fine. A hard power cycle will fix it as well.

It's like the C7 tries to phone home. When it does not get a response, it flags the connection as down and refuses to try again. It would be nice if it would continue trying until the issue is resolved. We shouldn't have to create a work around to reboot the hub, when it cannot phone home.

I have the same problem 1 hub works file the other goes down. Clicking on set time brings it back on even tho the time is correct. Switching time to a local time server did not help. Its clearly not the router or it would not come back when you click set time to browser.

This is a new problem as its been running for years. The only thing I did was update the firmware.

Try clicking on sync time to browser.

1 Like

How will that help, when the Hubitat is already showing the correct time?

I dont know but it connects to the cloud when you do that..
More than likely its forcing something to reset its state and that causes it to try and reconnect to the cloud. Try it

SO is there no solution to this. It did it 2 times today


Can you bump the firmware to the latest 2.3.9 and see if the issue still occurs?
I've done some tweaks to the reconnect logic lately.

1 Like