Cloud access broken after router swap

Hub: correct
Laptop: correct
iOS: correct
"browser": 1h off

No response from technical support. Out of options here. All cloud services (dashboards, mobile app) are down.

Have you tried to update the time? If so you may need to wait a few hours for the cloud connection to be reestablished. A time drift will prevent ths hub to connect to the cloud.

I'd also suggest rebooting the hub from the settings menu now that the router is stable. Sometimes the hub won't auto reconnect after an outage until it is rebooted although I haven't seen that with recent firmware updates myself.

Thanks, I have done that (many times), see steps 1-7 in my OP.

You mean via the Diagnostics tool? But the HUB time is correct:
Thu, 05 Nov 2020 11:25:xx CET

The "browser time" (I am currently on a DELL laptop) is
Thu, 05 Nov 2020 10:25:xx GMT

My browser time is picked up from my O/S? I am running Windows 10. Control Panel shows
Thu, 05 Nov 2020, 11:25:xx UTC+01:00

How do I get the browser time to be the same as my O/S time?

If I hit the "update" button in the diagnostics tool it says "succesfully updated time" but the same 1h difference per above remains.

Yesterday I fired up an older OS X laptop and when I used the diagnostics tool from it I could see the time for browser and hub were perfectly aligned. No time difference. I also did a hub reboot from this laptop but no joy, cloud still does not work. "No response from hub".

Device Time difference hub time - browser time
iOS iPhone Xs 1h
OS X laptop 0h
Win10 1h

A user with a similar problem, no resolution in the thread:

I restored back to After reboot I got the red flag notifying there is a new version available. I hit update and it tries to download but to no success, it never connects, see attached screenshot. @bobbyD image|375x500

It finally connected, but took >10-15 mins and was downloaded and applied.

The cloud access problem remains though

Any other ideas here on the forum on how to restore the cloud connection or things to test or check? A full reset and start from scratch with rebuilding my zwave network is not a tempting option... at all.

I have not received any suggestions from support, as of yet.

EDIT: I renamed this thread to "Cloud access broken"

Similar issue here:

Any suggestions @bobbyD?

a couple things to look at.. do you have upnp enabled in the router.. see if anything has reserved ports.. also did you put any ips in the dmz or port forwared that could be conflicting with port 80 or whatever ports the hubitat uses.. I assume you have it on a private ip and are using nat.. Also check if the new router has a firewall on.. some automatically do even though they are not overly necessary if using nat..

also depending on router if it has shell or http access or a test screen. you could try some the cloud urls yourself.

Have you tried NTP Client / Local NTP Server support ?? I use this to keep my hubs time in check.

also if it is just cloud dashboard access you can try resetting the token in the dashboard settings.. off course the url's will now change.

do you have upnp enabled in the router

upnp setting are under media server. it is off. have tried on or off, no change

see if anything has reserved ports

I have done no reservations, in fact no special router configuration at all aside from setting manual IPs for som devices including Hubitat

also did you put any ips in the dmz


or port forwared that could be conflicting with port 80


I assume you have it on a private ip and are using nat

Yes and yes

Also check if the new router has a firewall off

It is off

also depending on router if it has shell or http access or a test screen

You mean to try the cloud links from the router itself rather from a LAN client? Ok I will look into it

Have you tried [NTP Client / Local NTP Server support?

Thanks, but the time on my hub is accurate. It is the "browser time" that in some cases do not match the hub time. Not sure though as the system time for the operating system on which the browser (chrome, safari) is running, is also correct. I even tried the chrome timeshift plugin to have the browser's time match the hub's time but to no success

try resetting the token in the dashboard settings.

Thanks, I have tried that. See item 4 in my OP.

Update: Support is helping out and we have tried changing router settings from manual IP binding to dhcp and according to support things look better on the back ends but from my point of view it is still not working. "No response from hub" when trying cloud links or the mobile app from outside my LAN.

A positive side effect of all this trouble shooting and general cleaning up activities is that the hub is more responsive and faster than ever before!

Just wishing I could regain cloud access to it.

I somehow felt this was router related. Today I gave up on my Asus 4G-AC53U since netflix + chromecast also did not work for some mysterious reason. Returned it to the shop. Got a D-Link DWR-953 instead. Installed and everything - including Hubitat Cloud - now works just fine. So, the router it was but why? Anyway, all good. @bobbyD