Clicking on main RM app throws an error

I have moved almost everything over from my C5 to my C7 but have come to a serious issue. I cant get into the RM app. When clicking on Rule Machine I get this,

Looking tin the log I see this,


Any way to fix this? I cant delete the RM app and I cant add it again.

You can delete it by clicking on the gear icon, but Iโ€™d wait to see if thereโ€™s a way to fix it.

Have you moved all of your rules? If so, just delete the app from its App Status page. If not, send me a PM.

I used a backup from my C5 and restored it on the C7. I have deleted the RM app and installed it again.
I have an export of the rules as well and when importing rules from the exported file, there a few rules that throws me the error. I will re-create them after I have imported the ones that can be imported.

I am getting this now as well. I tried to clone a rule and that would not work it kept throwing an error, so I tried exporting and then importing the rule. That errored as well.

Now when I try to open RM I get same error shown above.

@bravenel I am unable to open RM as well now, is my only option to restore from backup.

Same error as shown in OP.

Want any info from me before I do?