Chromecast uriQ (message queue stalled)

Some related posts starting here:

Possible workaround:

I've been playing around with a Chromecast Audio and have found the same thing happening. I can press 'Initialize' in the device and that causes the queue to play out. I thought of using a periodic trigger in Rule Machine to refresh and initialize the device every 15 minutes, but those commands aren't available in RM for this device, even as a Custom Command.

Correction: I did figure out a Custom Command by using "Actuator" device.

I just started playing with my GH mini today. I'm having the same problem. When it decides to crap the bed it sends this error:

[dev:129] 2019-03-01 05:31:14.328 pm [error] su.litvak.chromecast.api.v2.ChromeCastException: No application is running in ChromeCast (runQ)

So today my hub was finally able to update to 2.0.6.112 and it appears to have solved this problem for me. I've been running a few hours without the GH Mini dropping out (previous record was 10-15 minutes).

Another workaround is Bryan's Notifier Plus, which has an option to initialize GH devices when doing TTS. I've been running it a few days now (replacing Alexa daily repeat reminders) and even my problem-child GHM has been working.

2 Likes

I have been using this rule for a while now and it seems to work keeping them awake when they need to be.

1 Like

This has been working for me for a while now.
"SmartTalk" is a group of Google Home mini's that I use for announcements.

Update: about 24 hours... and it crapped out again. Same error: su.litvak.chromecast.api.v2.ChromeCastException: No application is running in ChromeCast (runQ)

What I've noticed is that, when it's operating right, it returns a "media source is None" in the logs after Hubitat disconnects (exactly 5 minutes after the last notification is played). However, right before the API error, there's no "media source is None" message. So it seems like it stops communicating and then can't reconnect.

I guess I'm back to the "refresh()" workaround for now.

how do you get Command: initialize() Action?

Go into Rule Machine where you would create a new rule and, instead, select "Create Custom Commands". Once you create the custom command you can use it in a rule.

BTW, I've found that you only need the initialize() if your GH speakers aren't on a static IP. Otherwise, a simple refresh() appears to be adequate.

1 Like

Sorry for the spam guys, but this one is driving me nuts (and I'm driving the wife nuts testing it :smiley:).

I turned on the "Stop after TTS is complete" setting in the preferences section of the GH Mini device. It looks like it forces a disconnect after every announcement, which I believe lack of disconnect was leading to the errors. I've disabled my refresh() for now and will continue for the next several hours/days testing in this mode.

Two drawbacks I've noticed:

  1. Logging seems to be clipped when I do this. I don't get consistent logging of "speaker is playing", "speaker is idle", and "media source is Hubitat" events. But 100% consistency on "media source is None" within a couple seconds of the event.

  2. You get the new device connecting sound with EVERY event, regardless of how close together they are. Not a drawback for me, but I know others have said this drive them crazy. Guess it's good that I'm already crazy. :stuck_out_tongue_winking_eye:

1 Like

Got it thanks VERY much

"Stop after TTS complete" setting seems to have worked. I'm over 24 hours and everything is working fine without refreshes.

I'm still seeing inconsistent/incomplete logging. :-\

1 Like

Ok, while the GH mini hasn't gone offline since I turned on the "Stop after TTS complete" setting, it appears to truncate long messages (like notifications from @aaron's NOAA Weather Alerts). Hmmm.....

Does anyone know if there is a character limit for TTS? If there is I can do something similar to my PushOver character limitation. I have not personally run into any issues with TTS announcements with my NOAA application.

I believe it is 1024 characters. It used to be 128 but Mike increased it recently. See this discussion: 1.1.5 TTS: Sonos

currently there isn't a limit

1 Like

So there should be no reason for a long weather alert to be truncated correct?

Download the Hubitat app