Chromecast TTS only works on TVs not speakers

I couldn’t get TTS to work on Google Home Minis anymore, reinstalled Chromecast Integration and I can see all of my speakers (we have one Google Home speaker, several minis and two TVs), however only the TVs show a time of last connection and they are the only devices that TTS works on. The rules I created are functionally the same (I did try the speaker without the delay also, no change) but the one that plays to the tv works and the one that plays to the speaker doesn’t. Has anyone had a similar problem? Any recommendations on how to fix it?



Have you tried running the same speak command from the Device Details page for the speakers?

It's been a while since I used these in my setup, but I think I remember they used to need the initialize command run periodically.... But there's every chance that has been fixed recently.

Unfortunately I did try that, both the test TTS and the play audio file and they worked for the TV but not the speakers. Its so weird it clearly knows they exist but can't seem to interact in any way. I also verified that the IP addresses are correct so its not a mismatch there either.

Try turning on logging for both the rule and the devices involved and see if anything shows up there.

By your response, were you also meaning you had tried running the Initialize command?

Thanks just turned on the logging, and yes I did try to initialize as well, fingers crossed there’s something useful in the logs.

So the device log showed it couldn’t initialize, the rule log looks the same for the working device (kitchen tv) and the non-working device (hall tree speaker). I did notice a new state variable that I hadn’t noticed before, it looks like the hub trying to send the TTS to the speaker but I don’t know if that’s what it should look like or not.


I'm at a bit of a loss myself.... Any ideas @bobbyD ?