Chromecast Integration (beta) and Google WiFi

I just got Google WiFi and setup as a mesh network.

But now my Chromecast Integration (beta) is showing no devices.

Anything I can do to fix that?

How is your hubitat connected to the google wifi? Or are you running two independent networks?

An Arris router with wifi turned off. One Google WiFi hub plugged into the Arris router. The Hubitat is also plugged into the Arris router. No bridge mode.

That is the problem, you must plug Hubitat to the extra port in the Google WiFi

If you have multiple LAN devices and they are linked to Hubitat, a network switch is recommended connected to the extra port of Google wifi and all the devices to the switch including Hubitat.

1 Like

does it matter which one?

It has 2 ports, one is connected to your modem, then use the other

You are talking about google wifi, correct?

no I don't mean that

I have a primary point which is wired and two secondary wireless points. The easiest is to plug it into a secondary one but will that work?

No. Mesh routers automatically detect and switch accordingly.

1 Like

Yes it will work plugin it in a secondary, just look the primary what port is connected to your modem, then on the secondary use the other port, the one is not supposed to go to the modem.
I think in the secondary both ports works but just to make sure. I tested that a few days ago with a Hubitat hub.

now I can't access my hubitat

I can go to portal.hubitat but clicking on my hub gives me this error 2019-04-10_23h31_47

Perhaps @vjv has a different experience with Google WiFi, but I do not have this experience with my mesh router. The mesh routers I have used and installed for my clients can connect only two ethernet devices to the main access point. One is the ethernet connection from your ISP modem or modem/router. The second can host a computer (such as the Hubitat hub). If you need to connect more than one device to the main access point, then you must add an ethernet switch.

Additional access points which are connected to the main access point by wireless channel do not pass the data to the ethernet port on the secondary, tertiary, etc. access points. Only when the primary, secondary, tertiary, etc. extension access points are connected via ethernet backhaul, can the second ethernet port on the extensions be used for data access.

Again, I have no personal experience with Google WiFi, so perhaps it is different, but all other mesh routers I have experience with do not support that.

This doc shows a basic setup that may help guide how your hub needs to be connected for your situation.

This is normal, you need to reboot the hub to get a new IP, wait until the portal gets the new info, then you will have access, after that I recommend looking the hub in google wifi and reserve the IP so it will not change.

This is not true. I have a Netgear Orbi setup with one main router/access point and 3 satellite access points. The main router and 2 of the 3 satellites have 4 port switches built in. I can connect any device to any port on the main AP or the 2 satellites and they all pass data without issue. Nothing is connected via ethernet backhaul - everything is wireless.

I have setup and used other mesh systems (including Google WiFi) for clients and friends, and they all allow ethernet port data to pass without ethernet backhaul. If your setups did not, something was not configured properly. Google's own documentation for the Google WiFi product even describes how to add/connect a switch to a WiFi point. And, here's a quote from the Google WiFi help forum - "If you have multiple Google Wifi devices configured as a mesh, both ethernet ports on the secondary Wifi devices can be used to hard wire clients."

Not being able to use an ethernet/switch port unless the satellite access point is connected via ethernet backhaul, defeats the purpose of having ethernet ports built into the wireless satellite/AP.

1 Like

Thanks for the information.

I can access the Hubitat through my phone but not my through computer. My computer is wired and my phone is sharing the same wireless network as my hub.

I have gig internet and gig switches. I'm guessing I need to hook my on 16 port gig switch through the Google? I haven't because I was afraid of degraded performance. I have four ports on the back of my router. Currently I have one for the Google, one for the switch and one for work. Work cannot be changed.

Please check to see if your google wifi is in "Bridge Mode" otherwise you will create two separate networks, one in front of and behind the wifi setup.

No bridge mode. The mesh will not work if the primary is in bridge mode.

Thanks for the information and helping out. Maybe going forward you could tweak your responses to be a little more diplomatic. You even quoted me "mesh routers I have experience with". No where in my post does it say that I have experience with either a Netgear Orbi or Google WiFi.

If you're setting up a home network and you have the ability and desire to daisy chain the nodes via ethernet, this makes sense. The Linksys Velop I setup would not pass data to the Ethernet port when I tried (yes I rebooted all the nodes). Couldn't find anything in their documentation that said it could. Tried it with my TP-Link Deco M5 and also couldn't get a connection. Maybe it works, but it didn't work for me.

The info is helpful but lots of things in my home are hardwired and setting up my switch through a wireless point on second thought isn't ideal.

I'll have to move things around.