Chrome Cast Integration Issue

Hi all - Anyone else out there having issues with Chrome cast devices failing to play TTS?

Issue description:

I have some TTS notifications set up through the Notifier app using virtual switches but they have been working intermittently - As the messages stop working I then reboot the hub which fixes the issue for while then all of the sudden it will stop again in a few days. Last time I rebooted the hub, one of the devices ( JBL Link Smart display) played all the messages at once as if they'd been somehow queued before however this doesn't occur every time.

Troubleshooting I've performed:

  • Tried on Sonos speakers which worked as expected. I was actually using the Sonos speakers before and never had such issues with them at all but I recently switched to my chrome cast devices instead.

  • Tried on a Google nest mini which had the same outcome as the JBL Link speaker

  • Rebooted my modem which is already set to be rebooted once weekly but it made no difference as I retested the Notifier app

  • Rebooted the hub which temporarily fixed the issue

  • Last week when the issue occurred, I went into the Chrome Cast Integration app and tried rediscovering the devices but it kept failing to find all devices although they were all powered on and online. I tried this multiple times but had the same outcome. Once I rebooted the hub then it was able to discover all devices.

Logs captured:

As can be seen here, I turned the VS on and nothing played on the speaker:

Capture 4

Once I rebooted the hub it worked a expected:
Capture 3

Other facts:

  • I have static IP set to my wireless devices so a potential DHCP lease renewal wouldn't be a problem here.
  • Another strange thing that happened (perhaps a bit off topic) was that my mobile phone got logged out of the app and when I went to log back in then the app added it again (it wouldn't let me login otherwise) as a new device rather recognising that I was logging in with an existing phone. This then created a duplicate entry for my phone in my Devices list so I had to delete the redundant one and update every single rule which my phone was part of, so frustrating!!!

Any suggestions please?

Thanks in advance.

Use the Sonos integration or run CASTWEB API. The Chromecast Integration (beta) just seems to stop working or never works for TTS in some cases.

Try this. I use TTS on 8 Google assistant devices with rarely an issue. I honestly can't remember the last time an announcement didn't work.

1 Like

Problem with this is that if someone is watching TV the TTS will play but for some reason the TV doesn't resume playing afterwards so I have to manually go into the Sonos app to change it back to the TV.

If the TV is off it will play the TTS and the TV will be able to use the soundbar once it's turned on next however the TTS itself is rather low and the guy speaks way too fast so I set the volume to 50% which is a bit too loud for the TV hence I decided to stop using the Sonos speakers for TTS.

I am using all default settings for the Sonos integration so I am not sure if I need to change any settings there or whether the integration itself is just a bit flaky.

Will give this a shot as well as the suggestion from @oldcomputerwiz to see how it goes...

Where can I find instructions on how to set up 'CASTWEB API'? Is this a community based app?

I agree with what @oldcomputerwiz posted above ^^^^^

Try the Chromecast Helper app to work with the Chromecast Integration (beta) app (which seems to time out or disconnect sporadically). The Chromecast Help app re-initializes it on a time schedule that you can configure.

Use the server install instructions found here, but use this app and drivers for Hubitat Elevation compatibility.

The official Google TTS voices don't seem to work anymore, but the built-in HE TTS voices still work with it.

Yep, the Chromecast integration is poor. I use the helper app, guess it.... helps. But still I have mine disconnect on a regular basis. It's been beta for 2 years now so I'm assuming it's difficult to fix &/or sadly low priority for the HE team. I've found if I go into the device page and manually send a text message then it often starts working again. That at least saves a hub reboot.

I had similar problems and found that sending a volume command before a speech command works every time.

So now all of my rules sending TTS to my Google devices also have a volume command.

1 Like

Yeah, I wish the Hubitat team would either support it officially (not beta) or offer the source code up to the community so it can be developed further via open source


Thanks again for all the suggestions, that's much appreciated - I've been busy with work but I'll work on it again some time next week.

I second this strongly! :+1:

1 Like

I've just installed this though HPM so hopefully the issue will go away.

Thanks again, everyone.

1 Like

Download the Hubitat app