Changing IP Address Using "Switch to Static IP" Does Not Function

Using Hub C7 with version firmware.

When a new static IP is entered, the form feedback is "IP address must belong to subnet or you will not be able to communicate with the hub" when entered into "Switch to static IP" under "Network setup". Thus the new IP address never shows up in the Hubitat Hub Details listing and is not available for use.

To move the hub from to a new subnet at

The warning message is correct. However when using other devices the IP address changes and is no longer functions on its original subnet. The device must be reconnected to a different network and then the new subnet IP address will function.

Set up a Linksys EA8500 router "Obtain an IP address Automatically".
IPCONFIG reports the following on a laptop connected to the Linksys router.

IPv4 address -
Subnet Mask -
Drfault Gateway -

One would assume that connecting the hub to the router would enable the IP change to the subnet. However, at this point that is not happening.

Can this change of IP address be done across these two very different IP addresses? And if yes, what is the procedure.

Set the Hubitat to obtain it's address via DHCP. (Use the network reset button hidden on the bottom of the hub to reset it if it's still set to static).

Once it's on the same subnet as your laptop, log into your router and set a IP reservation (sometimes called something else like fixed) for your hub to the IP you want.

Using reserved IPs on the router allows you to manage all your addresses in one location without touching a client.


Removed both power and the internet from the C7 hub. Then connected to the Linksys router on the .55 subnet Internet first then power.

The hub powered up to the .55 subnet without the need for a physical reset. Kept the new IP and did not switch to a static address. Used find hubitat to locate the new IP address.

Now will test with various GET statements to make sure all of the cameras switch from day to night mode and back again.

Appreciate the 'how to' as it made the system work.

Thank you......