Chamberlain MyQ Garage Door Support [OUT OF DATE]

I'm controlling it with my hubitat through the MyQ cloud.

That is not true. Many manufacturers have what's called an API, which allows you to control your device from a webcall to the system. So, instead of having to interact with an app, you can send a command via the internet to the server to get it to do the same thing. That is how most of the cloud integrations work.

Whoops, yep you are correct. I wasn't thinking clearly after a long day at work.

No problem.

So I barely have any apps or drivers installed.

Has anyone experience slow downs with response to motion lighting slowing down using this app once the hub is been up for a few days?

I find I have to reboot the hub to get things responding quickly again.

Thank you so much for this comment! I was having the same issue and this was the nugget of gold I needed to get it working properly!

So I've noticed this has stopped working. I get Bad Requests every time I have habitat try and send a request.

app:6732019-10-18 11:28:47.544 pm Bad Request on line 924 (sendCommand)
app:6732019-10-18 11:28:47.143 pm debug[uri:, path:/api/v4/User/Validate, headers:[User-Agent:Chamberlain/3.73, BrandId:2, ApiVersion:4.1, Culture:en, MyQApplicationId:NWknvuBd7LoFHfXnKNMBcgajXtZEgKKh4V7WNzMidrpUUluDpVYVZx+xT4PCM5Kx], contentType:application/json; charset=utf-8, body:[username:HAHA_NO, password:NOT_POSTING_THIS]]

Anyone ran into this and fixed it?

It appears the token has expired. I would go back into the app and make sure that you can see the door there and that you haven't lost the token.

Same issue for me with a craftsman opener.

Looks like the smartthings app was just updated last night GitHub - brbeaird/SmartThings_MyQ: Integrate SmartThings with MyQ maybe @thomas.c.howard will port the changes over?

1 Like

To avoid these issues I’m exposing a virtual switch to HomeKit. Since HomeKit and MyQ are natively supported i don’t run into these issues.

I wish I could take it out if the mix and MyQ would natively support this for our hubs.

Yup...looks like this time it is totally broken for everybody, not just Chamberlain but Liftmaster too. Looks like I'll be coming up with a new solution today. Oh yay! (not)

Looks like its working with smartthings now with the recent update to their drivers.

Yeah, I looked at the changes and there are not just driver changes but there are a ton of changes to the app too.. So many that I couldn't reconcile them all. And loading the ST app doesn't work in HE. I can't print a report from it like I can with Beyond Compare (which I have for work) but Notepadd ++ has a great compare plugin. Load the two apps and compare them. There are more differences than similarities. WAAAAY beyond what I am capable of deciphering. There's no way to know if the difference is due to a necessary change to make it work with Hubitat or one for the update to the API.

Luckily, the door sensor I was using for the MyQ Lite was on a Hubduino board. So, I am just expanding that to have a door control device and running a wire over to the board from the opener. Cheapest alternative for me to get control back quickly.

its odd mine works great with the close command but the open does not any more.

app:10902019-10-19 14:16:48.330 Bad Request on line 922 (sendCommand)

So I'm guessing we have a long wait before someone takes the time to work on this?
I remember back in august there was an issue where the api changed for a night. and some other smart home system had an update. does that apply here?

I'm just using a momentary switch and a contact sensor. Easy to get those working with a rule to open/close.

MyQ reverted the changes. I don't recall any edits were done here as a result.

1 Like

You are correct @helene7t7, the changes were backed out shortly after being implemented. I guess we should have all been more ready for this change.

To be honest, I'v e wanted to get away from he MyQ being the only implementation I have since it is not 100% local. I do like having the wifi gateway as a backup is Hubitat is down but having total local control means I won't have a problem if my internet is down.

Also, if you're looking for a REALLY cheap alternative opener device, you can use any smartplug, an old 9v-12v wall-wart style power cord (how many of those do we all have laying around!) and simple $5 automotive relay. Simply set up Hubutit to turn the smartplug on for a second or two, wire the end of the wall-wart's plugs into the coil side of the relay and then the switch sides of the relay in parallel to your wall-button. Works like a charm and if you find stuff on sale you could do it for around $15-$20.

That said, I did try the update to the SmartThings app and it does work again. The nice part is that since it's a cloud integration, I didn't even have to power up my hub to use it. Just installed the updated app and drivers in the IDE and added the smartapp from the phone app. :slight_smile:

I decided to take a crack at reimplementing the app and driver. It needs to change over to the v5 API, which does give a decent amount of information. I'm not using any tilt sensors, so it's taking awhile to get through the code. Plus this is my first real crack at this, so it's taking a bit longer.

Obviously only testing with what I have, but currently I'm able to create my doors, and the open/close commands are successful.


I took a stab at it today and there are FAAAR too many complexities for me to wrap my head around it. I have come up with an alternate method to do this and I would recommend that anyone else who uses a MyQ opener come up with an alternate method as well as it appears that this is not going to be resolved anytime soon unless one of the more experienced Hubitat developers jumps in and tries to tackle it. I was able to get all the drivers and the app to save but it still doesn't work. It is not recognizing the returned values from the HTTP call even though they are returning the correct data. The problem is the methods for HTTP commands are different than ST.

I haven't spent a lot of time yet but I feel like this won't be too bad to make work. If you can wait an hour or two I can probably have a better idea if I can get it done today.